summaryrefslogtreecommitdiff
path: root/dev-python/pytest-skip-markers/pytest-skip-markers-1.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-skip-markers/pytest-skip-markers-1.5.0.ebuild')
-rw-r--r--dev-python/pytest-skip-markers/pytest-skip-markers-1.5.0.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/pytest-skip-markers/pytest-skip-markers-1.5.0.ebuild b/dev-python/pytest-skip-markers/pytest-skip-markers-1.5.0.ebuild
deleted file mode 100644
index bc066f65f3d5..000000000000
--- a/dev-python/pytest-skip-markers/pytest-skip-markers-1.5.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="A Pytest plugin which implements a few useful skip markers"
-HOMEPAGE="
- https://pytest-skip-markers.readthedocs.io/en/latest/
- https://github.com/saltstack/pytest-skip-markers
-"
-SRC_URI="
- https://github.com/saltstack/pytest-skip-markers/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/pytest-7.1.0[${PYTHON_USEDEP}]
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/distro[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pip[${PYTHON_USEDEP}]
- dev-python/pyfakefs[${PYTHON_USEDEP}]
- dev-python/pytest-subtests[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytestskipmarkers.plugin,pyfakefs.pytest_plugin
- epytest
-}