summaryrefslogtreecommitdiff
path: root/dev-python/pytest-runner/pytest-runner-2.11.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-runner/pytest-runner-2.11.1.ebuild')
-rw-r--r--dev-python/pytest-runner/pytest-runner-2.11.1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/pytest-runner/pytest-runner-2.11.1.ebuild b/dev-python/pytest-runner/pytest-runner-2.11.1.ebuild
deleted file mode 100644
index 498de4a1b938..000000000000
--- a/dev-python/pytest-runner/pytest-runner-2.11.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Adds support for tests during installation of setup.py files"
-HOMEPAGE="https://pypi.org/project/pytest-runner/ https://github.com/pytest-dev/pytest-runner"
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
-SLOT="0"
-IUSE="doc test"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- doc? (
- dev-python/rst-linker[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? ( ${RDEPEND} )
-"
-
-python_compile_all() {
- if use doc; then
- esetup.py build_sphinx
- HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
- fi
-}
-
-python_test() {
- esetup.py pytest
-}