summaryrefslogtreecommitdiff
path: root/dev-python/pytest-regressions
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-regressions')
-rw-r--r--dev-python/pytest-regressions/Manifest2
-rw-r--r--dev-python/pytest-regressions/pytest-regressions-2.6.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pytest-regressions/Manifest b/dev-python/pytest-regressions/Manifest
index 894885cb3b03..7dad764612a6 100644
--- a/dev-python/pytest-regressions/Manifest
+++ b/dev-python/pytest-regressions/Manifest
@@ -1,3 +1,5 @@
DIST pytest-regressions-2.5.0.tar.gz 113615 BLAKE2B 3364893a9cd96a44611d023c08fe5e319ceaad5a6a9b210b72095a560c42742c871406de1290821ea5cd61960bf5bef72d08bd143db93b20f288d5367cf1ae70 SHA512 2d23568b8d5dbc86000c9b552c72a1e269fafe79e0b829f799fe31ecc142e74d233c69940a51d2da457c6f7b3713fcd788461b0420eca9d56cc395568c517c0f
+DIST pytest_regressions-2.6.0.tar.gz 116150 BLAKE2B c6a5cfec055ef5a2ed0e615aff5211083633a542d08f48af6fdfd453c9a9c2992bb47e0d8a634ded1d1a753ae362dcf3a84db26f07a3d169635b286ea6af8760 SHA512 57248a851179c0f0cb840618cc529289b80d94a537b9e49f4a322405c92f8fd0baadb67472a577fe5fad2d3c22e44339663e86b1005cc831bb26e4b380d51fb1
EBUILD pytest-regressions-2.5.0.ebuild 1553 BLAKE2B 7bd952a11f86cfc620c1e2e57ff8827ec30d2fd375dd775085744736642a23c2c65bd1b1b5c63babde9540814b3a6d2ae3f8578d4552f9c15b0cfed21fb48fee SHA512 c2cd5bb71a50109c53a421fb8f4585b0dbd8272f6f74867099f705619b6d1894fb41b1a6795065c0044aaa7f879d5170e709d19ffdfff075cffd53e98f758052
+EBUILD pytest-regressions-2.6.0.ebuild 1541 BLAKE2B c23b071c358c3b4d2682b3e13f694644ddf01134e6109f9acca11c4eca3b475dc9219301b4546274cf4eeb533566f2ccaa114d6ef9fdef5dd8f2e6dfe829af20 SHA512 877ecc57fafbdc11ce40d3613aec7d6e33f8c0d319fbda5d8f4fbff45a38edc9f7e0d4dba2d9bde8d4bc05df942ec917ccdc7b6661ed9d9df09345161a5b03cf
MISC metadata.xml 409 BLAKE2B 1a8e013ab1ca1f4c780de085dd52334bc89b1410a10004bf0f70bdec351e32e80a2bbf9af85aae8faeb364f5698a5e5049bead2045b7fa598cad21ba2fa68b4b SHA512 16f824d0dd5b7fb5794c4f1c39ffb92e0705209811b899fa364ebfd457e137ec6b5f7e1a894087ad7ff6dda2715beaa799166fbedc10a133ada865f69af612b4
diff --git a/dev-python/pytest-regressions/pytest-regressions-2.6.0.ebuild b/dev-python/pytest-regressions/pytest-regressions-2.6.0.ebuild
new file mode 100644
index 000000000000..78519bbe3a8a
--- /dev/null
+++ b/dev-python/pytest-regressions/pytest-regressions-2.6.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easy to use fixtures to write regression tests"
+HOMEPAGE="
+ https://github.com/ESSS/pytest-regressions/
+ https://pypi.org/project/pytest-regressions/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-datadir[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/sphinx-rtd-theme
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ local EPYTEST_IGNORE=()
+ if ! has_version "dev-python/matplotlib[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_image_regression.py::test_image_regression
+ )
+ fi
+ if ! has_version "dev-python/numpy[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/test_ndarrays_regression.py
+ )
+ fi
+ if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_filenames.py::test_foo
+ tests/test_filenames.py::TestClass::test_foo
+ tests/test_filenames.py::TestClassWithIgnoredName::test_foo
+ )
+ EPYTEST_IGNORE+=(
+ tests/test_dataframe_regression.py
+ tests/test_num_regression.py
+ )
+ fi
+ if ! has_version "dev-python/pillow[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_image_regression.py
+ )
+ fi
+
+ epytest
+}