summaryrefslogtreecommitdiff
path: root/dev-python/pytest-localserver
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-localserver')
-rw-r--r--dev-python/pytest-localserver/Manifest2
-rw-r--r--dev-python/pytest-localserver/pytest-localserver-0.9.0_p0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pytest-localserver/Manifest b/dev-python/pytest-localserver/Manifest
index f87374544561..4a5b8f0bc577 100644
--- a/dev-python/pytest-localserver/Manifest
+++ b/dev-python/pytest-localserver/Manifest
@@ -1,3 +1,5 @@
+DIST pytest_localserver-0.9.0.post0.tar.gz 30280 BLAKE2B fa0a7f410a3a6c0fdda58a2118598dd97e60adc4dfca9474d66d390bc03fb8ac609a7c7ffea5d6f5843ffb6bae57a40749bfa833892188c4943bdd318c9a79ec SHA512 dfab24eb04d25fb725421041d1ac59f449141e996b0810706844df81469a26d2df9679ff4bca9a936c9d865977520d1b2ede6b95c4f8208375c4c679349b8ee5
DIST pytest_localserver-0.9.0.tar.gz 30222 BLAKE2B b452ef71045c8a157035d56a17f1debee15ee63ca3912d44c90e691b744216a2375980f728bb1d33ee41c527c7115ea975299d7d567b23a1ca1c5ce2dcf41dd7 SHA512 15aa2db9d5a9ca841499d455de7002cd2cb6288c165605f44bb88d5ce3e06b9ce02eacd226853734017fe41075e1cfcdd5cd5c422ee240086ef0cf95fc450011
EBUILD pytest-localserver-0.9.0.ebuild 935 BLAKE2B 7b74fc2bb59edba15422c7d2855a010a3e39ffed938c16daf5c877cf38121fd75da36137fc0f80b03c0d27300f3d1b9c5a13df9f74fe7e667268f62a844e9116 SHA512 3e54da6c1041ee943bc6ea885907e6f12281b23f3927fb3db93024cdd5e97438efcbdf5c493b622df02ececf0d4ca0d0b4739f0b7bc2b0574e878f48cad8fbb5
+EBUILD pytest-localserver-0.9.0_p0.ebuild 943 BLAKE2B f4a1dc484b51836485e2812ffba88b57be48b454253bb28458afd12d363767c3c00e3deb875fe39188548d06867b9e25b8738ce994d053bf2f3bc7aac7e801a3 SHA512 6abd6fb8718d1c8a42892c9e1fc7566bbdd4115944a95fc5a572c51beb0890df18fec1d1c10e19e14f72346c2ec91c16c9652b6c95186c0352c8e6f4b0bad698
MISC metadata.xml 415 BLAKE2B e9793de9ce60bde1549abb0983ca145f55261653324785d735c91785a20b61d949c228528faa742d669d52c1f456a36c65a93c1e9a692ec9297d4ffcfc0123fe SHA512 e0e7819a4b1bd41301824727b2204092986ba4d0c56fe1530b40543fcf7b90541933a7b8094f24a0573854b76b9ce11b7b42d2e38d135f61fed9b498f05f98e1
diff --git a/dev-python/pytest-localserver/pytest-localserver-0.9.0_p0.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.9.0_p0.ebuild
new file mode 100644
index 000000000000..276f8b5374a8
--- /dev/null
+++ b/dev-python/pytest-localserver/pytest-localserver-0.9.0_p0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin to test server connections locally"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-localserver/
+ https://pypi.org/project/pytest-localserver/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # requires aiosmtpd that is dead and broken beyond repair
+ tests/test_smtp.py
+)
+
+src_prepare() {
+ # remove aiosmtpd dep
+ sed -e '/aiosmtpd/d' -i setup.py || die
+ distutils-r1_src_prepare
+}