summaryrefslogtreecommitdiff
path: root/dev-python/pytest-localserver
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-localserver')
-rw-r--r--dev-python/pytest-localserver/Manifest2
-rw-r--r--dev-python/pytest-localserver/pytest-localserver-0.5.1.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pytest-localserver/Manifest b/dev-python/pytest-localserver/Manifest
index 8fe7100c408a..bf6ceb6040ca 100644
--- a/dev-python/pytest-localserver/Manifest
+++ b/dev-python/pytest-localserver/Manifest
@@ -1,5 +1,7 @@
AUX pytest-localserver-0.5.0-py310-tests.patch 1608 BLAKE2B d11471960e35b43150f2783b728e2f763e8b3b54a4a8a3fcc56fd12b6c230d03ffaa9826ee20c83865754c95b75c35343e3038d32b2e792fbf9975bbb936c961 SHA512 149526734f33dbb7903cf8381f6eca7cea7a0a3c452759a16d7a0ee8d415bd767722acde88189865eab769ff4506d209155df1e02e130effc724c4306f8cf99f
AUX pytest-localserver-0.5.0-setup.patch 170 BLAKE2B a82759d54b0ff9f7f457ca9e3665d68b05c92063ea4dd47bb4e5932999cb600aac9bda9367d33dc7911d0294932a30f52c618cd7f2f9b9db24b279efe64e79ab SHA512 75df9fe8dbcb38151478bb7039bb56a4fc00fea5f7867044ebab90260f7289930090f84727b1e449c95baa4fd275cd277fae5fcbad283e1f84ab72f6277d0926
DIST pytest-localserver-0.5.0.tar.gz 20409 BLAKE2B 62376065ee1aeb698ea5e3bd2d5ea3d6b511cc6793142aad458423513b0e3b358a0d0269a78a0f5aeda44fc53757ff85da786627840ee48cbed8b78ee34c2227 SHA512 aedf1e1c9563396457070df13df228ad0ebdd19173fa2ac5a598288d3e1a1ac8b8a0c0288cba0d8478e43d2e1de4848f2393bf640705916957f12ab31171c6cc
+DIST pytest-localserver-0.5.1.tar.gz 19341 BLAKE2B 759a90552b6f950579088a7c41448ad0f000aab980c56361d0e1a40d98a00ee234bf542a6309eb096602536da3fa819b7227a962d0592a801131a019f1617cdc SHA512 dad8b21020cf2f08ad03398b82bad7b47e553a9c6b489b94186bdc61c22f57e7151f8dbeab38ef42d03658104ec42920ec363288a1bdbea34dab6aee1da03c48
EBUILD pytest-localserver-0.5.0.ebuild 820 BLAKE2B 4f43eaf58d6fef25ea7203dde6921b5bacb1803295796112670ed47923491dc36a1d1b44698a9539992d9e4762ad57d25c4a2a020ec291c2bb98ee6163fbd360 SHA512 ad3e015bd199f171ff8947516f75f919151cc9955146ce638d0eb8abf41bd807bf5805828374b621e8149ac8ecf325910c0d957ae534dd7f3a5d08e9adcabdec
+EBUILD pytest-localserver-0.5.1.ebuild 703 BLAKE2B da608114945dc48e4f614e734256c2bf4d3112f5d66f3975a1b924a69d32d634b01502489988eedcfb78a01ca51ae85009262e9bce0573e2aee5a9e78b4be82c SHA512 5b7ac8c8cc685c6808419b7b7356ae6819964cc110e5595dd8d20282fec75be253eeb32378affdab9a488fd968ee4d2480cc1a6b9cfbb3ae7eb57b4fc836dd08
MISC metadata.xml 346 BLAKE2B 00f1243b0ef08f63d41fd211743230b93c976b52c5048bcdb2b5317610541a088ca13302e9c66e6a1a03156f071c5808d6960ccb1bfcf1349ba727f7ea608c25 SHA512 515a24e3a2fe049ad130ed44c1d42fb92ddf2f1bb4e512f8fce7e63b18af8529ae8790ca0dfc9b93589940c00fce192f1b16063936be26358e0e827afd359148
diff --git a/dev-python/pytest-localserver/pytest-localserver-0.5.1.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.5.1.ebuild
new file mode 100644
index 000000000000..91295943f329
--- /dev/null
+++ b/dev-python/pytest-localserver/pytest-localserver-0.5.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin to test server connections locally"
+HOMEPAGE="https://pypi.org/project/pytest-localserver/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND=">=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest