summaryrefslogtreecommitdiff
path: root/dev-python/pytest-localserver/pytest-localserver-0.6.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-localserver/pytest-localserver-0.6.0-r1.ebuild')
-rw-r--r--dev-python/pytest-localserver/pytest-localserver-0.6.0-r1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/pytest-localserver/pytest-localserver-0.6.0-r1.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.6.0-r1.ebuild
deleted file mode 100644
index 87ee974827cc..000000000000
--- a/dev-python/pytest-localserver/pytest-localserver-0.6.0-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Pytest plugin to test server connections locally"
-HOMEPAGE="https://pypi.org/project/pytest-localserver/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # requires aiosmtpd that is dead and broken beyond repair
- tests/test_smtp.py
-)
-
-src_prepare() {
- # remove aiosmtpd dep
- sed -i -e '/aiosmtpd/d' setup.py || die
- distutils-r1_src_prepare
-}