summaryrefslogtreecommitdiff
path: root/dev-python/pytest-isort/pytest-isort-0.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-isort/pytest-isort-0.3.1.ebuild')
-rw-r--r--dev-python/pytest-isort/pytest-isort-0.3.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pytest-isort/pytest-isort-0.3.1.ebuild b/dev-python/pytest-isort/pytest-isort-0.3.1.ebuild
new file mode 100644
index 000000000000..4f49aee54ec6
--- /dev/null
+++ b/dev-python/pytest-isort/pytest-isort-0.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for isort"
+HOMEPAGE="https://github.com/moccu/${PN} https://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/isort-4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.5[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ py.test -vs --cache-clear || die "testsuite failed under ${EPYTHON}"
+}