summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpx
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest2
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.12.1.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index b09cfe43c3ba..eedb37d353cf 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,3 +1,5 @@
DIST pytest-httpx-0.12.0.tar.gz 21319 BLAKE2B 59c3678937a7756f13971e3f1f8d312b227f56339b4234ac8e5544f4370622bcff401f76f68c2ee042fdc64deae6a7a9dd05ca8a54b60b14bfb74b2d2d724de4 SHA512 b5866ab0123755020fad679d27d4d113132b2a79da85c52a334904d19aea90ddc71088a6e0f27110498da2731be664c525f3cab256d447a37d9a507f9a508b43
+DIST pytest-httpx-0.12.1.tar.gz 21422 BLAKE2B 6336a79d3aedbba7ec32fdafc6ed6fd70a24354adcdd3803af73522f9eb2d5bb1ac51364c107d3ca663f2c627a29fa9d3b0c12ba1bcba94259932a36c7695ed4 SHA512 959906c366b3cfc4d3df46773888f1da0c65ca4a9d31de302c859a61a71f10df5712b058bf89132756028eda15c35241aa245bc708d69560a0d3a80f9fa1e814
EBUILD pytest-httpx-0.12.0.ebuild 653 BLAKE2B 49026b4a4108d22081b0cf24ae5921ce32b54c948b804b1c1ab6daf790f030f727738313862390b9c5b7a9f9761fb34b95a5ab8f6fbb70f0aea563a4aa2a1902 SHA512 fb68de7d314fcaf3e256854a6a882fac594e29ab4b331f25024da8d0092551279bf15a273089ee4174b7a7d29d8b8e8a96f58c21bf7fc919940bb0732671e5ee
+EBUILD pytest-httpx-0.12.1.ebuild 652 BLAKE2B a2624ce903778e87e6342263190c7ad41bf44b6fc85a293adb8f2be7b263bba58e277b00465fdd84eeac248a91525416560ad40f537d5642e6522e038c166867 SHA512 b8bf77a8d969b2dfc3681f080702add98e44a60bf4273484f8cb51b37cc77db3d2ebc381f179ad6366b667907ebcab7a2cfcc965a21961f3424c34878ad37712
MISC metadata.xml 467 BLAKE2B d13bfcccc41321e84d9e912be5e6106c376d7dd5a8bc596e69e570713fb2d0dee3627e29dc9c35c6638322c7edd328a6f60e6af8dc967fad302508dcfded32be SHA512 a6b6cc298ccbbc4b11c0e91a4402f634ee0f69e5ee53e09648f842771b8d6f3fdebe5114b3f55623b75e6539a794b6b94956a6eaf4e7f91e28eb6d4bcbb5f770
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.12.1.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.12.1.ebuild
new file mode 100644
index 000000000000..ce7fceeea820
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.12.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="https://colin-b.github.io/pytest_httpx/"
+SRC_URI="https://github.com/Colin-b/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.18*[${PYTHON_USEDEP}]
+ =dev-python/pytest-6*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest