summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpx/pytest-httpx-0.26.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-httpx/pytest-httpx-0.26.0.ebuild')
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.26.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.26.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.26.0.ebuild
new file mode 100644
index 000000000000..1926979c400c
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.26.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.25*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest