summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpx/pytest-httpx-0.21.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-httpx/pytest-httpx-0.21.1.ebuild')
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.21.1.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.21.1.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.21.1.ebuild
deleted file mode 100644
index 7d55391a5293..000000000000
--- a/dev-python/pytest-httpx/pytest-httpx-0.21.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/_}"
-DESCRIPTION="Send responses to HTTPX using pytest"
-HOMEPAGE="
- https://colin-b.github.io/pytest_httpx/
- https://github.com/Colin-b/pytest_httpx/
- https://pypi.org/project/pytest-httpx/
-"
-SRC_URI="
- https://github.com/Colin-b/pytest_httpx/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- =dev-python/httpx-0.23*[${PYTHON_USEDEP}]
- <dev-python/pytest-8[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest