summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpbin
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-httpbin')
-rw-r--r--dev-python/pytest-httpbin/Manifest3
-rw-r--r--dev-python/pytest-httpbin/files/pytest-httpbin-1.0.0-pypy3-hang.patch31
-rw-r--r--dev-python/pytest-httpbin/pytest-httpbin-1.0.0.ebuild30
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/pytest-httpbin/Manifest b/dev-python/pytest-httpbin/Manifest
index 2983a97e9c6d..0d654ffb4bfd 100644
--- a/dev-python/pytest-httpbin/Manifest
+++ b/dev-python/pytest-httpbin/Manifest
@@ -1,3 +1,6 @@
+AUX pytest-httpbin-1.0.0-pypy3-hang.patch 1099 BLAKE2B 4bb8dd686aadc35aab144a6467d52e7de675bcc7d6de8f130bc5942c17fd19c0c914d9aef81af3ed0a815ce21caf40ad8e7c8f724710fe07290dcc8fb92d6a24 SHA512 b0f417e7fdf658783e9297a895f50587d7b997de5065f5322fb46644028caa7cd10cf6130c578f6dd1f8b6aefbd281342f6aa8f5477284de3d4037b799604f72
DIST pytest-httpbin-0.2.3.tar.gz 9498 BLAKE2B ad41f72c80430eeea8c7f48185daf63c6adddfad36798179df27677aacc8af85419a678ba6f3df5281ca7f7ba0b3ee721cd97e5fe86eb5117417be53332f98e8 SHA512 f3c4eb67d1b02c27d8edb42622793fa3604e3f0bd5086e4986b8f0402a9fb8d7969a466be92fc6a7e301e829dbeb300183b40dccc9ec5da1d158cb4d08274f8b
+DIST pytest-httpbin-1.0.0.gh.tar.gz 17813 BLAKE2B b7e0ad9f131e4d236161b66b1d6d8e6087285a6d52df1accb044b30bcdac6c5f3350e9dbfe1cf33ab64b6d6aac6b463de81c31fd12dd950426b6ed8ef4eaf289 SHA512 2794134cc005cb969752e0c1119459d3f1e106f679942880a6b9ff507f2ee31c8ac4146a9c01b9a920368ea516443954b1b7044f7b1c270fe251f7d36adf7661
EBUILD pytest-httpbin-0.2.3.ebuild 870 BLAKE2B 4b8b26728c2fee47e1a6d0d18495510a1b75804df4ad5ac3f77543a1b7fdf15c30cbbe6d2d04c369611405814194d29faaf760ba4c4ae403e913ca05d9d5190e SHA512 713ee77f16dc3a9aa0c07506b43fc9282665bf4e1dadd787b2d8b28d1c1005ff8aa0b253c2697142c6c85400fdef9c6913a8d7bd7bab6c4cb339ec32a091248a
+EBUILD pytest-httpbin-1.0.0.ebuild 766 BLAKE2B a3094859fae4fe52252be865f284d21dca67299645ebbef9e5fdcf9ea82dc78d538945dd4d49769f109b8664f0ba3de0a06a847977ce9dc96356ac31625b987c SHA512 de725a577b5aa1114ce158742930e3d2c7e6fe41ba6275291bbc3f4209a0eed5a78c6416655a22a40830186d4e749b3f8f9d4f9ce0ada2afa9bd246762f58624
MISC metadata.xml 521 BLAKE2B f3135defad3eccac1a8f9a7188de8e375a970fd3b6c665395fad1d4ed570aa4a3a90728644fe45f13af527d5c51216e04631ddec670cb6ce5f026b508eb5f58f SHA512 19e78d9a8706ad253eb0f7873f0e8bf308065d4cdcafc6d2ebed792f31f526c1d4c45bd2f7aecac338bd30c4ebda33b301b056f3075c11231b8d0d5ad4e77d2e
diff --git a/dev-python/pytest-httpbin/files/pytest-httpbin-1.0.0-pypy3-hang.patch b/dev-python/pytest-httpbin/files/pytest-httpbin-1.0.0-pypy3-hang.patch
new file mode 100644
index 000000000000..02f63bffa72d
--- /dev/null
+++ b/dev-python/pytest-httpbin/files/pytest-httpbin-1.0.0-pypy3-hang.patch
@@ -0,0 +1,31 @@
+diff -dupr a/pytest_httpbin/serve.py b/pytest_httpbin/serve.py
+--- a/pytest_httpbin/serve.py 2019-02-11 20:54:14.000000000 +0100
++++ b/pytest_httpbin/serve.py 2019-11-22 15:50:17.407769297 +0100
+@@ -116,6 +116,7 @@ class Server(object):
+
+ def stop(self):
+ self._server.shutdown()
++ self._server.socket.close()
+
+ @property
+ def url(self):
+Only in b: pytest_httpbin.egg-info
+Only in b/tests: __pycache__
+diff -dupr a/tests/test_httpbin.py b/tests/test_httpbin.py
+--- a/tests/test_httpbin.py 2019-02-11 20:54:14.000000000 +0100
++++ b/tests/test_httpbin.py 2019-11-22 15:59:53.955324547 +0100
+@@ -1,3 +1,4 @@
++import sys
+ import unittest
+ import requests
+ import pytest_httpbin
+@@ -40,6 +41,8 @@ def test_httpbin_join(httpbin):
+ def test_httpbin_str(httpbin):
+ assert httpbin + '/foo' == httpbin.url + '/foo'
+
++@unittest.skipIf(hasattr(sys, 'pypy_version_info')
++ and sys.hexversion >= 0x03000000, 'hangs on PyPy3')
+ def test_chunked_encoding(httpbin_both):
+ assert requests.get(httpbin_both.url + '/stream/20').status_code == 200
+
+Only in b: .tox
diff --git a/dev-python/pytest-httpbin/pytest-httpbin-1.0.0.ebuild b/dev-python/pytest-httpbin/pytest-httpbin-1.0.0.ebuild
new file mode 100644
index 000000000000..316237426a43
--- /dev/null
+++ b/dev-python/pytest-httpbin/pytest-httpbin-1.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily test your HTTP library against a local copy of httpbin"
+HOMEPAGE="https://github.com/kevin1024/pytest-httpbin
+ https://pypi.org/project/pytest-httpbin/"
+SRC_URI="https://github.com/kevin1024/pytest-httpbin/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/httpbin[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/pytest-httpbin-1.0.0-pypy3-hang.patch
+)
+
+distutils_enable_tests pytest