summaryrefslogtreecommitdiff
path: root/dev-python/pyte/pyte-0.8.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyte/pyte-0.8.0-r1.ebuild')
-rw-r--r--dev-python/pyte/pyte-0.8.0-r1.ebuild14
1 files changed, 3 insertions, 11 deletions
diff --git a/dev-python/pyte/pyte-0.8.0-r1.ebuild b/dev-python/pyte/pyte-0.8.0-r1.ebuild
index b4ea4d05ae87..880144fbda60 100644
--- a/dev-python/pyte/pyte-0.8.0-r1.ebuild
+++ b/dev-python/pyte/pyte-0.8.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -16,14 +16,10 @@ SRC_URI="https://github.com/selectel/pyte/archive/${PV}.tar.gz -> ${P}.tar.gz"
SLOT="0"
LICENSE="LGPL-3"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
+
+distutils_enable_tests pytest
python_prepare_all() {
# run pytest directly for tests
@@ -31,7 +27,3 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-
-python_test() {
- py.test -v || die "tests failed with ${EPYTHON}"
-}