summaryrefslogtreecommitdiff
path: root/dev-python/pysvn
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pysvn')
-rw-r--r--dev-python/pysvn/Manifest4
-rw-r--r--dev-python/pysvn/files/pysvn-1.8.0-respect_flags.patch99
-rw-r--r--dev-python/pysvn/metadata.xml8
-rw-r--r--dev-python/pysvn/pysvn-1.8.0.ebuild59
4 files changed, 170 insertions, 0 deletions
diff --git a/dev-python/pysvn/Manifest b/dev-python/pysvn/Manifest
new file mode 100644
index 000000000000..0456e3609a00
--- /dev/null
+++ b/dev-python/pysvn/Manifest
@@ -0,0 +1,4 @@
+AUX pysvn-1.8.0-respect_flags.patch 4633 BLAKE2B 5063e9491623033155fd59f97ef794ae1fd8205b0588b369395b5e021d40646fd8e65387bd27b5daa95d43f1f573059e88de5cf266b76b98d3d85834039e8ea6 SHA512 e573b995e45f7129b0e52e702ce1793180b7b2c3ef3ccebc8f1b16af9454beeca581f2486eae519437f41cd195c0dc6535c51e9dcef1258dffa57f5a99c4600b
+DIST pysvn-1.8.0.tar.gz 366583 BLAKE2B b7aae274bd2387901df4075ffa70d73e4462a127aa6690aecc406288a9e8dc2f31599297480cfc5fef14ef39c47daa3c309b6c61f49d781abb4d8c0f9a9fcb12 SHA512 14a70b910be986eba638a903edde5046c93314fedb08a7c15d464dc51da1c7efeb87147cc68c00ff9ac1b4ca506d099d3aedf7e4d86f92642c7304ef9540653b
+EBUILD pysvn-1.8.0.ebuild 1258 BLAKE2B 87b37e284add11986278b2a48ba5baf806203dba9a54fc459fb560c43e4ce16a23aad926967e77d57827644f856633d254988deb789e7291707ed2567de422a2 SHA512 4ba46661a8cd444db7464b620febb35858b14666cdefa591306e6ca9b73bc1690c411606839467f3787594d431ce5b384f2fbb088b3a01e64d9e73ea3c3792f9
+MISC metadata.xml 240 BLAKE2B 41e6a4d9da33dab2decc5ff419924f382a8f64d27a81fdb97576db8c6cf125be95911747946ec8be1b453f56617fef1084f5947f84b50a8db419d46df2ae8a0f SHA512 9c23321eaa853f851bf00195ea64ac2ba093e516f9b57855ee5aa58fbb1988130c9f0c17c2a9ce9fae4ee033e0a28a70c868e0f5acdfa1dd316ab533c5279d59
diff --git a/dev-python/pysvn/files/pysvn-1.8.0-respect_flags.patch b/dev-python/pysvn/files/pysvn-1.8.0-respect_flags.patch
new file mode 100644
index 000000000000..9b4c3a075e8f
--- /dev/null
+++ b/dev-python/pysvn/files/pysvn-1.8.0-respect_flags.patch
@@ -0,0 +1,99 @@
+ Source/setup_configure.py | 26 +++++++++++++-------------
+ 1 file changed, 13 insertions(+), 13 deletions(-)
+
+diff --git a/Source/setup_configure.py b/Source/setup_configure.py
+index afeee2d..47f2717 100644
+--- a/Source/setup_configure.py
++++ b/Source/setup_configure.py
+@@ -849,8 +849,8 @@ class CompilerGCC(Compiler):
+ def __init__( self, setup ):
+ Compiler.__init__( self, setup )
+
+- self._addVar( 'CCC', 'g++' )
+- self._addVar( 'CC', 'gcc' )
++ self._addVar( 'CCC', '$(CXX)' )
++ self._addVar( 'CC', '$(CC)' )
+
+ def getPythonExtensionFileExt( self ):
+ return '.so'
+@@ -976,8 +976,8 @@ class MacOsxCompilerGCC(CompilerGCC):
+ else:
+ arch_options = ''
+
+- self._addVar( 'CCC', 'g++ %s' % (arch_options,) )
+- self._addVar( 'CC', 'gcc %s' % (arch_options,) )
++ self._addVar( 'CCC', '$(CXX) %s' % (arch_options,) )
++ self._addVar( 'CC', '$(CC) %s' % (arch_options,) )
+
+ self._find_paths_pycxx_dir = [
+ '../Import/pycxx-%d.%d.%d' % pycxx_version,
+@@ -1032,11 +1032,11 @@ class MacOsxCompilerGCC(CompilerGCC):
+
+ def setupUtilities( self ):
+ self._addVar( 'CCCFLAGS',
+- '-g '
++ '$(CXXFLAGS) '
+ '-Wall -fPIC -fexceptions -frtti '
+ '-I. -I%(APR_INC)s -I%(APU_INC)s -I%(SVN_INC)s '
+ '-D%(DEBUG)s' )
+- self._addVar( 'LDEXE', '%(CCC)s -g' )
++ self._addVar( 'LDEXE', '$(CXX) $(LDFLAGS)' )
+
+ def setupPySvn( self ):
+ self._pysvnModuleSetup()
+@@ -1048,7 +1048,7 @@ class MacOsxCompilerGCC(CompilerGCC):
+ self._addVar( 'PYTHON_INC', distutils.sysconfig.get_python_inc() )
+
+ py_cflags_list = [
+- '-g',
++ '$(CXXFLAGS) ',
+ '-Wall -fPIC -fexceptions -frtti',
+ '-I. -I%(APR_INC)s -I%(APU_INC)s -I%(SVN_INC)s',
+ '-DPYCXX_PYTHON_2TO3 -I%(PYCXX)s -I%(PYCXX_SRC)s -I%(PYTHON_INC)s',
+@@ -1074,13 +1074,12 @@ class MacOsxCompilerGCC(CompilerGCC):
+
+ self._addVar( 'CCCFLAGS', ' '.join( py_cflags_list ) )
+ self._addVar( 'LDLIBS', ' '.join( py_ld_libs ) )
+- self._addVar( 'LDSHARED', '%(CCC)s -bundle -g '
++ self._addVar( 'LDSHARED', '$(CXX) $(LDFLAGS) -bundle '
+ '-framework System '
+ '%(PYTHON_FRAMEWORK)s '
+ '-framework CoreFoundation '
+ '-framework Kerberos '
+- '-framework Security '
+- '%(LDLIBS)s' )
++ '-framework Security' )
+
+ class UnixCompilerGCC(CompilerGCC):
+ def __init__( self, setup ):
+@@ -1140,11 +1139,11 @@ class UnixCompilerGCC(CompilerGCC):
+
+ def setupUtilities( self ):
+ self._addVar( 'CCCFLAGS',
+- '-g '
++ '$(CXXFLAGS) '
+ '-Wall -fPIC -fexceptions -frtti '
+ '-I. -I%(APR_INC)s -I%(APU_INC)s -I%(SVN_INC)s '
+ '-D%(DEBUG)s' )
+- self._addVar( 'LDEXE', '%(CCC)s -g' )
++ self._addVar( 'LDEXE', '$(CXX) $(LDFLAGS)' )
+
+ def setupPySvn( self ):
+ self._pysvnModuleSetup()
+@@ -1155,6 +1154,7 @@ class UnixCompilerGCC(CompilerGCC):
+ self._addVar( 'PYTHON_ARCH_SPECIFIC_INC', distutils.sysconfig.get_python_inc( True ) )
+
+ py_cflags_list = [
++ '$(CXXFLAGS)',
+ '-Wall -fPIC -fexceptions -frtti',
+ '-I. -I%(APR_INC)s -I%(APU_INC)s -I%(SVN_INC)s',
+ '-DPYCXX_PYTHON_2TO3 -I%(PYCXX)s -I%(PYCXX_SRC)s -I%(PYTHON_INC)s',
+@@ -1176,7 +1176,7 @@ class UnixCompilerGCC(CompilerGCC):
+
+ self._addVar( 'CCCFLAGS', ' '.join( py_cflags_list ) )
+ self._addVar( 'LDLIBS', ' '.join( self._getLdLibs() ) )
+- self._addVar( 'LDSHARED', '%(CCC)s -shared -g' )
++ self._addVar( 'LDSHARED', '$(CXX) $(LDFLAGS) -shared' )
+
+ #--------------------------------------------------------------------------------
+ class LinuxCompilerGCC(UnixCompilerGCC):
diff --git a/dev-python/pysvn/metadata.xml b/dev-python/pysvn/metadata.xml
new file mode 100644
index 000000000000..7f4f33c6dbc9
--- /dev/null
+++ b/dev-python/pysvn/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pysvn/pysvn-1.8.0.ebuild b/dev-python/pysvn/pysvn-1.8.0.ebuild
new file mode 100644
index 000000000000..76f70b6b2510
--- /dev/null
+++ b/dev-python/pysvn/pysvn-1.8.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit eutils distutils-r1 toolchain-funcs
+
+DESCRIPTION="Object-oriented python bindings for subversion"
+HOMEPAGE="http://pysvn.tigris.org/"
+SRC_URI="http://pysvn.barrys-emacs.org/source_kits/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="doc examples"
+
+DEPEND="
+ >=dev-python/pycxx-6.2.6[${PYTHON_USEDEP}]
+ dev-vcs/subversion"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-respect_flags.patch )
+
+DISTUTILS_IN_SOURCE_BUILD=true
+
+python_prepare_all() {
+ # Don't use internal copy of dev-python/pycxx.
+ rm -r Import || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ cd Source || die
+ # all config options from 1.7.6 are all already set
+ esetup.py configure
+}
+
+python_compile() {
+ cd Source || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+}
+
+python_test() {
+ cd Tests || die
+ emake
+}
+
+python_install() {
+ cd Source || die
+ python_domodule pysvn
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Docs/. )
+ use examples && local EXAMPLES=( Examples/Client/. )
+ distutils-r1_python_install_all
+}