summaryrefslogtreecommitdiff
path: root/dev-python/pysvn/pysvn-1.9.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pysvn/pysvn-1.9.11.ebuild')
-rw-r--r--dev-python/pysvn/pysvn-1.9.11.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/pysvn/pysvn-1.9.11.ebuild b/dev-python/pysvn/pysvn-1.9.11.ebuild
deleted file mode 100644
index 94cf5b5d4488..000000000000
--- a/dev-python/pysvn/pysvn-1.9.11.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_IN_SOURCE_BUILD=true
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Object-oriented python bindings for subversion"
-HOMEPAGE="https://pysvn.sourceforge.io/"
-SRC_URI="mirror://sourceforge/project/pysvn/pysvn/V${PV}/${P}.tar.gz"
-
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-IUSE="doc examples"
-
-DEPEND="
- >=dev-python/pycxx-7.0.2[${PYTHON_USEDEP}]
- >=dev-vcs/subversion-1.9"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}"/${P}-respect-flags.patch )
-
-python_prepare_all() {
- # Don't use internal copy of dev-python/pycxx.
- rm -r Import || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure() {
- cd Source || die
- # all config options from 1.7.6 are all already set
- esetup.py configure
-}
-
-python_compile() {
- cd Source || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
-}
-
-python_test() {
- cd Tests || die
- emake
-}
-
-python_install() {
- cd Source || die
- python_domodule pysvn
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( Docs/. )
- if use examples; then
- docinto examples
- dodoc -r Examples/Client/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}