summaryrefslogtreecommitdiff
path: root/dev-python/pysrt/pysrt-1.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pysrt/pysrt-1.1.2.ebuild')
-rw-r--r--dev-python/pysrt/pysrt-1.1.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pysrt/pysrt-1.1.2.ebuild b/dev-python/pysrt/pysrt-1.1.2.ebuild
new file mode 100644
index 000000000000..766998ae2d3e
--- /dev/null
+++ b/dev-python/pysrt/pysrt-1.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python library used to edit or create SubRip files"
+HOMEPAGE="https://github.com/byroot/pysrt https://pypi.org/project/pysrt/"
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/byroot/pysrt.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests -v || die "Tests failed under ${EPYTHON}"
+}