summaryrefslogtreecommitdiff
path: root/dev-python/pysnmp/pysnmp-999999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pysnmp/pysnmp-999999.ebuild')
-rw-r--r--dev-python/pysnmp/pysnmp-999999.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/dev-python/pysnmp/pysnmp-999999.ebuild b/dev-python/pysnmp/pysnmp-999999.ebuild
index 10dccaf53f2d..3e79289ba474 100644
--- a/dev-python/pysnmp/pysnmp-999999.ebuild
+++ b/dev-python/pysnmp/pysnmp-999999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-inherit distutils-r1 git-r3
+PYTHON_COMPAT=( python3_{7..10} )
+inherit distutils-r1 git-r3 optfeature
DESCRIPTION="Python SNMP library"
HOMEPAGE="https://pypi.org/project/pysnmp/ https://github.com/etingof/pysnmp"
@@ -37,8 +37,7 @@ python_install_all() {
}
pkg_postinst() {
- elog "You may also be interested in the following packages: "
- elog "dev-python/pysnmp-apps - example programs using pysnmp"
- elog "dev-python/pysnmp-mibs - IETF and other mibs"
- elog "dev-python/pysmi - to dump MIBs in python format"
+ optfeature "Example programs using pysnmp" dev-python/pysnmp-apps
+ optfeature "IETF and other mibs" dev-python/pysnmp-mibs
+ optfeature "Dump MIBs in python format" dev-python/pysmi
}