summaryrefslogtreecommitdiff
path: root/dev-python/pyscard
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyscard')
-rw-r--r--dev-python/pyscard/Manifest2
-rw-r--r--dev-python/pyscard/pyscard-2.2.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pyscard/Manifest b/dev-python/pyscard/Manifest
index 4cdc7f51fc3b..070b90042b02 100644
--- a/dev-python/pyscard/Manifest
+++ b/dev-python/pyscard/Manifest
@@ -1,3 +1,5 @@
DIST pyscard-2.1.1.tar.gz 153537 BLAKE2B 60c6d8acae5f707f84f8dfa775b2bfc74e4c6075b10a64c5ba1854b7c4e6cd03e2fa8db337b48ec5a167b834a4b22f5ae182ec4e78463b549aa8f4980295dbfd SHA512 854d52fde447e972545761ce8f2c1262d5e454c942fc68f2be09d0b62cc453aa5ef793e899f283fe5f53db59ef0714252090b8f5335dcd1b40ed28506965f371
+DIST pyscard-2.2.0.tar.gz 154847 BLAKE2B 4941ddb8b5ba38855eb69d61432241fc181e7fff7c181eb9d40ae03f0e4ce5818483d2ea35e25e92033f946e5f3e17aad297c02b3c90def91f79c24941bc80bf SHA512 91ceeab576345ff7f2e9d173399ab4d2ddebd26dab613fba33b7620253aea81645d6efdf0d365724a34cec8e9fd4f76cd43801d925a94e058ff797e5c0a41b73
EBUILD pyscard-2.1.1.ebuild 867 BLAKE2B 0b346a9802fcb46e4d3c9ef97874153c50df8b52695b5a3ff3b453902d9ff843f2f953d9b7ef8eccee49ae9c97c818dd66021f96fbb7ca8e730fa014b5a99b91 SHA512 2ac17178ac98706ccddde1a8548294fbea82b613d91733049fc35f00d8e9fd19a35ccf8f744d23b278f9cdb243454555d964d5cb92d7960fc771f3aeea0ee582
+EBUILD pyscard-2.2.0.ebuild 822 BLAKE2B afc1155e5ab1f09c471ad4de2016fb891bc4433b35a46e58b6b82f48fa186e9372c57858f5907a9f508c70703142f98cbe12d121851a94ba41607ea806b00a41 SHA512 cc6244684a5020d67d194398951f993533cc0e5278e2b3e716dbcc8f382bc25f77bf73242eb8209de2ba27029476231bd0bb5b8bab490121fa63b0aab6dd4fa6
MISC metadata.xml 426 BLAKE2B a4819bd37d610cf785d4b0e5ba2a709c941000d5cea8e20c8d49e513e7167b55e8e149da9e318281dce7b4eb92cb61e355054c273e3758262c6c25a0757ffba3 SHA512 82e759791154362704f4d7a1a1c72d53710e405c21bf791d0ec609ddfee4b8c04e3490a3f33f8d0e6e295f3b8433520f328dd71bc91cde2926a89a76803fd63d
diff --git a/dev-python/pyscard/pyscard-2.2.0.ebuild b/dev-python/pyscard/pyscard-2.2.0.ebuild
new file mode 100644
index 000000000000..516826e3e3d7
--- /dev/null
+++ b/dev-python/pyscard/pyscard-2.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Smart card support in python"
+HOMEPAGE="
+ https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard/
+ https://pypi.org/project/pyscard/
+"
+SRC_URI="
+ https://downloads.sourceforge.net/project/pyscard/pyscard/pyscard%20${PV}/${P}.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ sys-apps/pcsc-lite
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/swig
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/Pyro4
+}