summaryrefslogtreecommitdiff
path: root/dev-python/pyscard
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyscard')
-rw-r--r--dev-python/pyscard/Manifest2
-rw-r--r--dev-python/pyscard/pyscard-2.2.1.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pyscard/Manifest b/dev-python/pyscard/Manifest
index d053cb24246f..446d945b444d 100644
--- a/dev-python/pyscard/Manifest
+++ b/dev-python/pyscard/Manifest
@@ -1,3 +1,5 @@
DIST pyscard-2.2.0.tar.gz 154847 BLAKE2B 4941ddb8b5ba38855eb69d61432241fc181e7fff7c181eb9d40ae03f0e4ce5818483d2ea35e25e92033f946e5f3e17aad297c02b3c90def91f79c24941bc80bf SHA512 91ceeab576345ff7f2e9d173399ab4d2ddebd26dab613fba33b7620253aea81645d6efdf0d365724a34cec8e9fd4f76cd43801d925a94e058ff797e5c0a41b73
+DIST pyscard-2.2.1.tar.gz 156518 BLAKE2B b68dace8a9b4b6cdae20b23d6e7d8838e0ad64e229d5a3a5e4a8fc5c1edeb16a6d7bd162c57cfdd7d5e5c56c0370f121a71e498e463b42b509bc97dce10ef14c SHA512 7a09211743c56473e7c1d034acf4b08402b41462da36b35fe45617511dc9bc5fa704e0d1d5102277a44c4aee216e84b019b5cff188eda255b32de0c7517c58d3
EBUILD pyscard-2.2.0.ebuild 843 BLAKE2B c92e81e32ea36d645a5bb9b8b741b1f98994edc3b7dbd72dac926af0897ab4c8666c8d833494feafda9fca475966bbf63121031a1fb0f0cb2e18f115448d1866 SHA512 024a31a5382c22d1a4118b07b6a622851c40a5184e72c98217e5ce21aff9b3cedc49f87fc5691a0da65ad1bead7fc7a5e6f15a6fcac12c11f7cf19bedae053f7
+EBUILD pyscard-2.2.1.ebuild 846 BLAKE2B a1cac2c97d51f590884ff3e14f4148489a4fd5774b8e922f32fcce65c8f593313d5b958b67d9ab42c875a761b75d5b676667dbc220cc9ba87022232ca525123f SHA512 b5ddf3b8a9ae3caa9c3236010116c0a2e613458be2b9160c3a44bfb50f1de73acd7d5792ad09626642b508908c5a1aea05d455723aa56d30d3942c25a2504acc
MISC metadata.xml 426 BLAKE2B a4819bd37d610cf785d4b0e5ba2a709c941000d5cea8e20c8d49e513e7167b55e8e149da9e318281dce7b4eb92cb61e355054c273e3758262c6c25a0757ffba3 SHA512 82e759791154362704f4d7a1a1c72d53710e405c21bf791d0ec609ddfee4b8c04e3490a3f33f8d0e6e295f3b8433520f328dd71bc91cde2926a89a76803fd63d
diff --git a/dev-python/pyscard/pyscard-2.2.1.ebuild b/dev-python/pyscard/pyscard-2.2.1.ebuild
new file mode 100644
index 000000000000..68e78542f37b
--- /dev/null
+++ b/dev-python/pyscard/pyscard-2.2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Smart card support in python"
+HOMEPAGE="
+ https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard/
+ https://pypi.org/project/pyscard/
+"
+SRC_URI="
+ https://downloads.sourceforge.net/project/pyscard/pyscard/pyscard%20${PV}/${P}.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND="
+ sys-apps/pcsc-lite
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/swig
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/Pyro4
+}