summaryrefslogtreecommitdiff
path: root/dev-python/pyscard/pyscard-2.0.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyscard/pyscard-2.0.5.ebuild')
-rw-r--r--dev-python/pyscard/pyscard-2.0.5.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pyscard/pyscard-2.0.5.ebuild b/dev-python/pyscard/pyscard-2.0.5.ebuild
new file mode 100644
index 000000000000..acbc37af89b9
--- /dev/null
+++ b/dev-python/pyscard/pyscard-2.0.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Smart card support in python"
+HOMEPAGE="
+ https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard/
+ https://pypi.org/project/pyscard/
+"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ sys-apps/pcsc-lite
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/swig
+"
+
+distutils_enable_tests unittest
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/Pyro4
+}
+
+python_test() {
+ cd test || die
+ eunittest
+}