summaryrefslogtreecommitdiff
path: root/dev-python/pyrsistent/pyrsistent-0.19.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyrsistent/pyrsistent-0.19.3.ebuild')
-rw-r--r--dev-python/pyrsistent/pyrsistent-0.19.3.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/dev-python/pyrsistent/pyrsistent-0.19.3.ebuild b/dev-python/pyrsistent/pyrsistent-0.19.3.ebuild
index fe0aaaa964b9..82bedd9eff6a 100644
--- a/dev-python/pyrsistent/pyrsistent-0.19.3.ebuild
+++ b/dev-python/pyrsistent/pyrsistent-0.19.3.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 pypi
@@ -26,3 +26,15 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=()
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_IGNORE+=(
+ # probably a bug in python itself or in hypothesis
+ tests/hypothesis_vector_test.py
+ )
+ fi
+
+ epytest
+}