summaryrefslogtreecommitdiff
path: root/dev-python/pyqtgraph
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyqtgraph')
-rw-r--r--dev-python/pyqtgraph/Manifest4
-rw-r--r--dev-python/pyqtgraph/pyqtgraph-0.12.1.ebuild86
-rw-r--r--dev-python/pyqtgraph/pyqtgraph-0.12.2.ebuild2
3 files changed, 2 insertions, 90 deletions
diff --git a/dev-python/pyqtgraph/Manifest b/dev-python/pyqtgraph/Manifest
index 31e590c44c82..bd2049f73270 100644
--- a/dev-python/pyqtgraph/Manifest
+++ b/dev-python/pyqtgraph/Manifest
@@ -1,6 +1,4 @@
-DIST pyqtgraph-0.12.1.tar.gz 899513 BLAKE2B 17f6dec41039186ceb0afdfbcba64aebf5900d17b890d9a6d1f8a30586a27e3cc61bb1d3a8fb2446f9ee3a66c54095b7c5d37b5c5fb83296b481d8a95a7fdab5 SHA512 b1ed004c7db4ee4f8302a42dd9e8574692b4c353bf512ec7a42d5ebeaab126e9ed5df3a228c631dc77e16a61efce1c918cbd0a8b319649e346e2082215c56d40
DIST pyqtgraph-0.12.2.tar.gz 1292676 BLAKE2B af5e61bbc7f55cda669825a9742a3f2424638d35e3a10b85b7fc635a5e40b630848bed1e88bc84383cbd3e85de538b1b1fa051d6d761b368209c1d8167f55a2a SHA512 8a7f0e1e78cf147568ee6e393a07f07301632765d1bdb50328fcf1f815dda76f3e89808cef945409dcd9142407f864f205778a76cf804d4cbce544c60bcf5042
DIST pyqtgraph-test-data-8.tar.gz 306068 BLAKE2B f3aa418dfaf2e74950fa880da4b6dfb4ef5dbd46346b78065d885c1f9fc06fc3de86756af17e27035d4cd47d98cc7ce58c036b493837b568086a4ebceb230c78 SHA512 07ef414f2b57e00589f8c18459e88ab16001c7cc3766164cdfcd69faa26cbc90ed64611fd0c5e3b401dc6a3f1a6e9e4ce6a7d9fa96ebcc4360e03fa9fbb856d2
-EBUILD pyqtgraph-0.12.1.ebuild 2357 BLAKE2B 813534be9225f64cbd2d9d6539d24092cdb0338a494ef10066628f01ed2bc108a70a6233db56db5e25ccb1a1ca9c34648be4e817c244f3be3dbeb0b86b46a901 SHA512 54207e530efd6dd391e7162bc68942cbf2a4e41885d4f19a16061038f9623145c13d8617e112e66db94e3b2e1d590fa789c37c314895882e88cd9a1e74774a55
-EBUILD pyqtgraph-0.12.2.ebuild 2450 BLAKE2B e867cc19b84e0ddb1057ddd468669202beab38a73135ea4643e4e4a1a9458b35da0e1d9cd660fc61e629928f7749145c6e8cb0d1aee7dc5d08bd803adea2c3b9 SHA512 df1454e4bde7b7a6b693702ec7180a604644a7dec4c48c264d25262dc63137d95f114a08f5d0a03c22eb5840cb3f0007fe0d933d92c102512456cbfb4586e9c7
+EBUILD pyqtgraph-0.12.2.ebuild 2448 BLAKE2B 4ce693ffec4c109bf20367ac3d0d9524ccadb4c4d357420b18bac88dc18d830cc5337d683fb3aa1cf11f088d42da23e6d9adab10d359ead8098c28f318bbf113 SHA512 a1af7760bfb2756c3539101fd45cd7fbb3de8e83fcd6adaf661eac569f243fadede2012900d2c775c3733f265eba56e18fc7e7e9780db1c8893e42b744636089
MISC metadata.xml 774 BLAKE2B 4e4c11fc145888225b343a740b67918f0409426868c44725040ed16f200a1d1a7a51ae10398aeba1ecb3285c0d18a847845dd546958efac1c2688fd67b04c423 SHA512 d9f564b82d4d90f88606dc5badd7818289a4cfd8ae8b9658e36278bedcdad441c067e212d9988bc0d9098946c63e1a233698acb5c60a90e93bda244990fae4b2
diff --git a/dev-python/pyqtgraph/pyqtgraph-0.12.1.ebuild b/dev-python/pyqtgraph/pyqtgraph-0.12.1.ebuild
deleted file mode 100644
index cdc658825f76..000000000000
--- a/dev-python/pyqtgraph/pyqtgraph-0.12.1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1 multiprocessing virtualx
-
-TEST_DATA_TAG=test-data-8
-DESCRIPTION="A pure-python graphics and GUI library built on PyQt and numpy"
-HOMEPAGE="http://www.pyqtgraph.org/ https://pypi.org/project/pyqtgraph/"
-SRC_URI="
- https://github.com/pyqtgraph/pyqtgraph/archive/${P}.tar.gz
- test? (
- https://github.com/pyqtgraph/test-data/archive/${TEST_DATA_TAG}.tar.gz
- -> ${PN}-${TEST_DATA_TAG}.tar.gz
- )"
-S=${WORKDIR}/${PN}-${P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="examples opengl svg"
-
-RDEPEND="
- >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/PyQt5[gui,widgets,opengl=,svg=,${PYTHON_USEDEP}]
- opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )"
-BDEPEND="
- test? (
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/PyQt5[svg,testlib,${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-distutils_enable_sphinx doc/source
-distutils_enable_tests pytest
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-
- if use test; then
- mkdir "${HOME}"/.pyqtgraph || die
- mv "${WORKDIR}/test-data-${TEST_DATA_TAG}" \
- "${HOME}"/.pyqtgraph/test-data || die
- cd "${HOME}"/.pyqtgraph/test-data || die
- # we need to fake a git repo
- git config --global user.email "you@example.com"
- git config --global user.name "Your Name"
- git init -q || die
- git commit -q --allow-empty -m "dummy commit" || die
- git tag "${TEST_DATA_TAG}" || die
- cd - >/dev/null || die
- fi
- if ! use opengl; then
- rm -r pyqtgraph/opengl || die
- fi
-}
-
-python_test() {
- local deselect=(
- # apparently fragile
- --deselect pyqtgraph/tests/test_reload.py::test_reload
-
- # pyside2 is normally skipped if not installed but these two
- # fail if it is installed
- # TODO: this could be due to USE flags, revisit when pyside2
- # gains py3.9
- --deselect
- 'examples/test_examples.py::testExamples[ DateAxisItem_QtDesigner.py - PySide2 ]'
- --deselect
- 'examples/test_examples.py::testExamples[ designerExample.py - PySide2 ]'
- )
-
- distutils_install_for_testing
- virtx epytest "${deselect[@]}" \
- -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
-}
-
-python_install_all() {
- use examples && DOCS+=( examples/ )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pyqtgraph/pyqtgraph-0.12.2.ebuild b/dev-python/pyqtgraph/pyqtgraph-0.12.2.ebuild
index 523718072f98..3bc55a927f18 100644
--- a/dev-python/pyqtgraph/pyqtgraph-0.12.2.ebuild
+++ b/dev-python/pyqtgraph/pyqtgraph-0.12.2.ebuild
@@ -19,7 +19,7 @@ S=${WORKDIR}/${PN}-${P}
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="examples opengl svg"
RDEPEND="