summaryrefslogtreecommitdiff
path: root/dev-python/pypy/pypy-7.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pypy/pypy-7.3.0.ebuild')
-rw-r--r--dev-python/pypy/pypy-7.3.0.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-python/pypy/pypy-7.3.0.ebuild b/dev-python/pypy/pypy-7.3.0.ebuild
index 23373c0fbe6e..255575b2dbe7 100644
--- a/dev-python/pypy/pypy-7.3.0.ebuild
+++ b/dev-python/pypy/pypy-7.3.0.ebuild
@@ -52,6 +52,23 @@ src_prepare() {
eapply -p2 "${WORKDIR}/${PATCHSET}"/0010-use_pyxml.patch
popd > /dev/null || die
+ # this test relies on pypy-c hardcoding correct build time paths
+ sed -i -e 's:test_executable_without_cwd:_&:' \
+ lib-python/2.7/test/test_subprocess.py || die
+ # this one seems to rely on cpython gc handling (?)
+ sed -i -e 's:test_number_of_objects:_&:' \
+ lib-python/2.7/test/test_multiprocessing.py || die
+ # hardcoded assumptions (?)
+ sed -i -e 's:test_alpn_protocols:_&:' \
+ -e 's:test_default_ecdh_curve:_&:' \
+ lib-python/2.7/test/test_ssl.py || die
+ # requires Internet
+ sed -i -e '/class NetworkedTests/i@unittest.skip("Requires networking")' \
+ lib-python/2.7/test/test_ssl.py || die
+ # TODO: investigate (sandbox?)
+ sed -i -e 's:test__copy_to_each:_&:' \
+ lib-python/2.7/test/test_pty.py || die
+
eapply_user
}