summaryrefslogtreecommitdiff
path: root/dev-python/pypugjs/pypugjs-5.9.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pypugjs/pypugjs-5.9.8.ebuild')
-rw-r--r--dev-python/pypugjs/pypugjs-5.9.8.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pypugjs/pypugjs-5.9.8.ebuild b/dev-python/pypugjs/pypugjs-5.9.8.ebuild
new file mode 100644
index 000000000000..5301bcefc4e1
--- /dev/null
+++ b/dev-python/pypugjs/pypugjs-5.9.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="Pug (Jade) syntax adapter for Django, Jinja2 and Mako templates"
+HOMEPAGE="https://github.com/kakulukia/pypugjs"
+SRC_URI="https://github.com/kakulukia/pypugjs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/chardet
+"
+DEPEND="${RDEPEND}"