summaryrefslogtreecommitdiff
path: root/dev-python/pyproject-api/pyproject-api-1.6.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyproject-api/pyproject-api-1.6.1.ebuild')
-rw-r--r--dev-python/pyproject-api/pyproject-api-1.6.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyproject-api/pyproject-api-1.6.1.ebuild b/dev-python/pyproject-api/pyproject-api-1.6.1.ebuild
new file mode 100644
index 000000000000..89015d483f8a
--- /dev/null
+++ b/dev-python/pyproject-api/pyproject-api-1.6.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="API to interact with the python pyproject.toml based projects"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-api/
+ https://pypi.org/project/pyproject-api/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-23.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.3.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.11.1[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-68.1.2[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.40.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_frontend_setuptools.py::test_setuptools_prepare_metadata_for_build_wheel
+ # requires Python 2 installed
+ tests/test_frontend.py::test_can_build_on_python_2
+)