summaryrefslogtreecommitdiff
path: root/dev-python/pyphen/pyphen-0.11.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyphen/pyphen-0.11.0-r1.ebuild')
-rw-r--r--dev-python/pyphen/pyphen-0.11.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyphen/pyphen-0.11.0-r1.ebuild b/dev-python/pyphen/pyphen-0.11.0-r1.ebuild
new file mode 100644
index 000000000000..6483d12818a0
--- /dev/null
+++ b/dev-python/pyphen/pyphen-0.11.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for hyphenation using hunspell dictionaries"
+HOMEPAGE="https://github.com/Kozea/Pyphen"
+SRC_URI="https://github.com/Kozea/Pyphen/archive/${PV}.tar.gz -> ${P^}.tar.gz"
+S=${WORKDIR}/${P^}
+
+LICENSE="GPL-2+ LGPL-2+ MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ >=dev-python/pyproject2setuppy-18[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # avoid dep on extra plugins
+ sed -i -e '/addopts/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}