summaryrefslogtreecommitdiff
path: root/dev-python/pyotherside
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyotherside')
-rw-r--r--dev-python/pyotherside/Manifest2
-rw-r--r--dev-python/pyotherside/pyotherside-1.6.0.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/pyotherside/Manifest b/dev-python/pyotherside/Manifest
index e35006999516..a5ef6fff1c36 100644
--- a/dev-python/pyotherside/Manifest
+++ b/dev-python/pyotherside/Manifest
@@ -1,3 +1,5 @@
DIST pyotherside-1.5.9.tar.gz 185230 BLAKE2B 7130f17f29ed07cefc641d77631db46d08f3bd836c8517427e38fb454cbf34c2e875bb46798b3d785aa68064c24f154ed166617cde263f722e77eac6d0903980 SHA512 62c171b273b921d8e0220c7b73f0ff95a0a911eb3785cc37f3dab2ec624e54301ac5fbccfb57cac6a4bee967728624d4738b03aff0c5762452b99674cdff6ab2
+DIST pyotherside-1.6.0.tar.gz 183645 BLAKE2B e2a12a9a96f3672a5e322c9f2e84d485b8086bdcacfc6586e0c23f6dd730d3e66cea66618540fd9a304480a9ab86386e2fe0136047c59f70bfa3b5cff9e8e76e SHA512 57835db9d65fae10e6b3ec8ab37793e316324e7a819a1045436adf9eabdee11ccf3090a4db0302283b236e77e5e0bd14cf92ed1430835ccc324e50085a872787
EBUILD pyotherside-1.5.9.ebuild 838 BLAKE2B 02180271c9cc5793dc50a05b1431f18020a593c6312ff3722acd27d81d1e39b50beab5e9fe12bed62f8b13861718b075476d12b7d741b0b8e2ec8ce036922213 SHA512 e9dbc395b578731ad81f3fb98a0102cf8e1ee49b60845cccf811065455c8401e7e52a3a1029510e45e5d7cb882904b2c9bab5809b87d0dd5792f4f6579a620c8
+EBUILD pyotherside-1.6.0.ebuild 1366 BLAKE2B 6956aa658e7e71612ab8397eceeef01e83ef2b78497b4efc2d79eb0d702100fa672561589c24d12b3a91ebeb96cffa4376a402df70d313b58dd4d23fc56bbeb2 SHA512 d63655d63482d03b3e291e384d65b9fd83977de5c1152b02a0f7a5f675fae832cbd770d2facfe3366cf51b5e5b610a1b6507f930ab72422724b5c0fe9ebeaf64
MISC metadata.xml 326 BLAKE2B c323223e1038b40f67b25b1f13a4f5fec61175ef0b73bd3ec3a4228bb51b0a41e0f27ca2f47ec9f2b595e07a83358c74f254054d06b4488ff25d2a1c046899b4 SHA512 9d4649f09f1a00a9aa4a8eeb4e535ceff6b924253cd3ac93a8c0d1f6fe2a94c02a7f14f5b722b7b39744ab7331cd3efb57dc59bcb7ab6fb5ce59f692c0f2718a
diff --git a/dev-python/pyotherside/pyotherside-1.6.0.ebuild b/dev-python/pyotherside/pyotherside-1.6.0.ebuild
new file mode 100644
index 000000000000..355a5418a120
--- /dev/null
+++ b/dev-python/pyotherside/pyotherside-1.6.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit qmake-utils python-single-r1
+
+DESCRIPTION="Asynchronous Python 3 Bindings for Qt"
+HOMEPAGE="https://github.com/thp/pyotherside https://thp.io/2011/pyotherside/"
+SRC_URI="https://github.com/thp/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv"
+IUSE="+qt5 qt6"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ ^^ ( qt5 qt6 )"
+
+# qt6 TODO:
+# - add dev-qt/qt{gui,opengl}:6 once in the tree, test if qt6 deps okay then
+# - instrument qmake6 (no eqmake6 in the eclass yet)
+# - multibuild for both qt5 and qt6 if requested
+RDEPEND="
+ ${PYTHON_DEPS}
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtsvg:5
+ )
+ qt6? (
+ dev-qt/qtbase:6
+ dev-qt/qtdeclarative:6
+ dev-qt/qtsvg:6
+ )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i -e "s/qtquicktests//" pyotherside.pro || die
+}
+
+src_configure() {
+ if use qt5; then
+ eqmake5
+ elif use qt6; then
+ die "Qt6 support is not ready yet"
+ else
+ # This should never happen if REQUIRED_USE is enforced
+ die "Neither Qt5 nor Qt6 support enabled, aborting"
+ fi
+}
+
+src_test() {
+ QT_QPA_PLATFORM="offscreen" tests/tests || die
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}