summaryrefslogtreecommitdiff
path: root/dev-python/pyopenssl
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyopenssl')
-rw-r--r--dev-python/pyopenssl/Manifest2
-rw-r--r--dev-python/pyopenssl/pyopenssl-23.3.0.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/pyopenssl/Manifest b/dev-python/pyopenssl/Manifest
index 0885bca88ccb..c926e0329ce0 100644
--- a/dev-python/pyopenssl/Manifest
+++ b/dev-python/pyopenssl/Manifest
@@ -1,3 +1,5 @@
DIST pyOpenSSL-23.2.0.tar.gz 185132 BLAKE2B 06330623bf5934b89cf88dee508c2c4bdd170f805a111f082624b2f8c59fd56e48d5954ef7d9f98768e88aaabaa9e04594ea717784a86401e6e64433e699c9b8 SHA512 a467801bf94959a067d9d3551b47d17d4798bf0b87d253d41a89cac9cdb1731a967a98bda3e83ab8a560ed5fdc0a17f34604f3c6e0f6789bc4c920bc49f520c9
+DIST pyOpenSSL-23.3.0.tar.gz 183043 BLAKE2B 63ef42c63ec96db320e85b8aae8441ff8378b3ed3b5ad780d7d7f4b07bd70649da2d1f0d433bee7c162c6c8b6c430e9547b695af0851cd38f8b1d14649577da5 SHA512 e75ffd9922798d7bb08be50782a2185aaf69cdc41e4c83e0c904d7b7b3b5da3bbfe73abe965eb0bfe1b325de79eb9f72f16a05444f0310ebfaf8f5bf8ce1fe87
EBUILD pyopenssl-23.2.0.ebuild 1510 BLAKE2B f8973cb7183fbd757288b9613b57cd4099fcb0918af279d1c9f9c26cdd15295372f4639a694c46f2f7ac91946c1d691f04037529de34532b43a1302f142fb86e SHA512 c18420f02195b8e2a7cfb6e5dffa04210c27ccef673fb66593dbb87101479c9aafd3e9eceff6208a249cbeb4ff37f367b19892c0e13420024583f2d1867e7ef0
+EBUILD pyopenssl-23.3.0.ebuild 1517 BLAKE2B cad1432fe0394d8af230525a02424156027aef51ae1b3d198e7e6f8be45b55c69dfc4b0a6e643446cfac8ee13fa8ebba84a68405075652208cca473b3b312a70 SHA512 a20c2ce920481bd619befcec0b6ad9336f2993f4eb485a90041327003c346c2107a83ccb00e9b95fc05b30f2539df020b92c164ea965ec01f256c1a12611fa35
MISC metadata.xml 536 BLAKE2B 86db822042b6fb3e965ece87b6b15dcabf76cdfbfa76ba285a491208ad5c6a2a196ca7144a1a73b152decc4df1641ad4c57a1cbde9f90d09d25eef1f6f4da39a SHA512 996d0e20291e744c6c20b38fd750d242920541aca7d92de63ca5b1dcc2f1c10308545797ccf499f38e50dfd04db2bb031e93b02c7c1705908f2363c813294ff1
diff --git a/dev-python/pyopenssl/pyopenssl-23.3.0.ebuild b/dev-python/pyopenssl/pyopenssl-23.3.0.ebuild
new file mode 100644
index 000000000000..e88cdc417eed
--- /dev/null
+++ b/dev-python/pyopenssl/pyopenssl-23.3.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+PYPI_NO_NORMALIZE=1
+PYPI_PN=pyOpenSSL
+
+inherit distutils-r1 toolchain-funcs pypi
+
+DESCRIPTION="Python interface to the OpenSSL library"
+HOMEPAGE="
+ https://www.pyopenssl.org/
+ https://github.com/pyca/pyopenssl/
+ https://pypi.org/project/pyOpenSSL/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/cryptography-42[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-41.0.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+src_test() {
+ local -x TZ=UTC
+ local EPYTEST_DESELECT=(
+ tests/test_ssl.py::TestContext::test_set_default_verify_paths
+ )
+
+ # test for 32-bit time_t
+ "$(tc-getCC)" ${CFLAGS} ${CPPFLAGS} -c -x c - -o /dev/null <<-EOF &>/dev/null
+ #include <sys/types.h>
+ int test[sizeof(time_t) >= 8 ? 1 : -1];
+ EOF
+
+ if [[ ${?} -eq 0 ]]; then
+ einfo "time_t is at least 64-bit long"
+ else
+ einfo "time_t is smaller than 64 bits, will skip broken tests"
+ EPYTEST_DESELECT+=(
+ tests/test_crypto.py::TestX509StoreContext::test_verify_with_time
+ )
+ fi
+
+ distutils-r1_src_test
+}