summaryrefslogtreecommitdiff
path: root/dev-python/pyoembed/pyoembed-0.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyoembed/pyoembed-0.1.1.ebuild')
-rw-r--r--dev-python/pyoembed/pyoembed-0.1.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pyoembed/pyoembed-0.1.1.ebuild b/dev-python/pyoembed/pyoembed-0.1.1.ebuild
new file mode 100644
index 000000000000..3b6c54f2f8c2
--- /dev/null
+++ b/dev-python/pyoembed/pyoembed-0.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for oEmbed with auto-discovered and manually added providers"
+HOMEPAGE="https://github.com/rafaelmartins/pyoembed"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=
+ KEYWORDS=
+ EGIT_REPO_URI="https://github.com/rafaelmartins/pyoembed.git"
+ inherit git-r3
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}