summaryrefslogtreecommitdiff
path: root/dev-python/pynacl/pynacl-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pynacl/pynacl-1.2.0.ebuild')
-rw-r--r--dev-python/pynacl/pynacl-1.2.0.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-python/pynacl/pynacl-1.2.0.ebuild b/dev-python/pynacl/pynacl-1.2.0.ebuild
deleted file mode 100644
index 95e57102b313..000000000000
--- a/dev-python/pynacl/pynacl-1.2.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6})
-
-inherit distutils-r1
-
-DESCRIPTION="Python binding to the Networking and Cryptography (NaCl) library"
-HOMEPAGE="https://github.com/pyca/pynacl/ https://pypi.org/project/PyNaCl/"
-SRC_URI="https://github.com/pyca/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
-IUSE="test"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/cffi-1.4.1[${PYTHON_USEDEP}]
- dev-libs/libsodium:0/23
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}] )
-"
-
-src_prepare() {
- # For not using the bundled libsodium
- export SODIUM_INSTALL=system
- distutils-r1_python_prepare_all
-}