summaryrefslogtreecommitdiff
path: root/dev-python/pylint
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest4
-rw-r--r--dev-python/pylint/pylint-3.3.1.ebuild92
-rw-r--r--dev-python/pylint/pylint-3.3.2.ebuild2
3 files changed, 2 insertions, 96 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 6f415c7d7323..f4b512fc1a19 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,5 +1,3 @@
-DIST pylint-3.3.1.gh.tar.gz 1453572 BLAKE2B e756d72c0757a8d90491fddaa5a60cccedde043b4dbaf9162ccabd920bbb864bf109f619483474748a606dedb4bf889a57edb447ef77a40c7ee35e2019caf277 SHA512 86cb0019f53477346de44a7cf22b6ee6ec791d2cfc23ec0c1ffcc749752d52f255aa5dcfaaf7b124706ce8a87013d5e592c0896c527e10b8df06c974f440d3c6
DIST pylint-3.3.2.gh.tar.gz 1454335 BLAKE2B dba68aead7d2babe885d4a94220e61ddc6c5759bd9703d2bbeb1c7d1c68b6bebce7cbe6d7b0cc18a7c8cfe32b7e0cc6be929e021e7a9223ae31839185c07558f SHA512 48f57bc74a47c8658cad9ede6bb8540077c72fc6b3e8d9d401ddd1d43daaf547637ad253af885ac503a79aa31c30de1b4b302c4d4001a18b68e064e505975980
-EBUILD pylint-3.3.1.ebuild 2408 BLAKE2B 504a5559a36d94e351fe619945695b718b380c2f8671c8fc29556b4c2be7db2450535e67e8556ade5f34c8289e37e96adf10dbec576f0b8f4d975f55417584ef SHA512 250d4c374a74ec2d7b72c1ee88e1e7e849b16795760820e7b0b2c761b4b34f940ca0322e9760c3bf98c86003c3525200662f79e3f6a5b92fd532077fa84fc3fb
-EBUILD pylint-3.3.2.ebuild 2416 BLAKE2B 283a910ff4bc02aecdca3319796045bb67116ec83e611aebe869225b3fe76ff7ea5507827a57d0e4df2fdb29834e5cfd5d1c647b92c80187b647ba24b045bafd SHA512 922e71235d7026e76bb779e99fd051ab8babb9773a0e86a5bc5f3af02da31ae95096f9fc6a6faf3a771f7d623183b99c663cd3f5c59cc9676ed6a973bf20dded
+EBUILD pylint-3.3.2.ebuild 2408 BLAKE2B 2fd36a744eda25c399697c1d5c4668da583f0a32141707a126655405ef175689f3780c9ea9f8dab0841ad8d3f253d48ed55273214abff8c17f257cb7d3f35379 SHA512 e36dad4f1ab76f98b39b2a8a8c004f9e004f38b38c14c7392cea672b42e51038bab87ea77610c9c02ba2f2d8c4a789611cbb46c1f9ffb3569c66333d72a758b9
MISC metadata.xml 1105 BLAKE2B aa9d049b732f9198685901a0ec31f4a615da8398ce1741558e7b2c3840890da0c5ac6a2a23e0fd4cd45fb443b92f69b3fe4fb7f9d7570b1a75a0d0784231f392 SHA512 5f5bb3e31554bdc0cdcdaf1d7df9194e32da649784124714783c5d280c7ab4a9f65317b5d5e6de47698b2f30a019051191cb7ef3066902b606e2582a31f01c05
diff --git a/dev-python/pylint/pylint-3.3.1.ebuild b/dev-python/pylint/pylint-3.3.1.ebuild
deleted file mode 100644
index d50526bae845..000000000000
--- a/dev-python/pylint/pylint-3.3.1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-MY_P=${P/_beta/b}
-DESCRIPTION="Python code static checker"
-HOMEPAGE="
- https://pypi.org/project/pylint/
- https://github.com/pylint-dev/pylint/
-"
-SRC_URI="
- https://github.com/pylint-dev/pylint/archive/v${PV/_beta/b}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="examples"
-
-RDEPEND="
- <dev-python/astroid-3.4[${PYTHON_USEDEP}]
- >=dev-python/astroid-3.3.4[${PYTHON_USEDEP}]
- >=dev-python/dill-0.3.7[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- <dev-python/isort-6[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- >=dev-python/gitpython-3[${PYTHON_USEDEP}]
- ' 'python*' )
- >=dev-python/pytest-8.3[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- >=dev-python/typing-extensions-4.12[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO
- 'tests/test_functional.py::test_functional[dataclass_with_field]'
- 'tests/test_functional.py::test_functional[no_name_in_module]'
- 'tests/test_functional.py::test_functional[shadowed_import]'
- 'tests/test_functional.py::test_functional[use_yield_from]'
- 'tests/test_functional.py::test_functional[wrong_import_order]'
- )
- local EPYTEST_IGNORE=(
- # No need to run the benchmarks
- tests/benchmark/test_baseline_benchmarks.py
- )
-
- if ! has_version "dev-python/gitpython[${PYTHON_USEDEP}]"; then
- EPYTEST_IGNORE+=(
- tests/profile/test_profile_against_externals.py
- tests/testutils/_primer/test_package_to_lint.py
- tests/testutils/_primer/test_primer.py
- )
- fi
-
- rm -rf pylint || die
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p timeout
-}
-
-python_install_all() {
- if use examples ; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pylint/pylint-3.3.2.ebuild b/dev-python/pylint/pylint-3.3.2.ebuild
index 5ac06d70fb6c..a29067b0bba9 100644
--- a/dev-python/pylint/pylint-3.3.2.ebuild
+++ b/dev-python/pylint/pylint-3.3.2.ebuild
@@ -23,7 +23,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="examples"
RDEPEND="