summaryrefslogtreecommitdiff
path: root/dev-python/pyjwt
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyjwt')
-rw-r--r--dev-python/pyjwt/Manifest2
-rw-r--r--dev-python/pyjwt/pyjwt-2.9.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyjwt/Manifest b/dev-python/pyjwt/Manifest
index 9a347fe71428..8082bea2a414 100644
--- a/dev-python/pyjwt/Manifest
+++ b/dev-python/pyjwt/Manifest
@@ -1,3 +1,5 @@
DIST PyJWT-2.8.0.tar.gz 78313 BLAKE2B b5031ec0ea672ef2dffc077aba6c781a20a7497257a16241841c0e0158017370581e3c9785d930772290c25fc9029e71a5d8744d999b135b29715a4f35720508 SHA512 74e74cf8c78494a9e51a2a186347361388031d5c0d0864df2a5d051621d9d31dff617ab1d7ebb4a829cc7d409d196e1bdb3b361ec888b6c14f1abea77544475e
+DIST pyjwt-2.9.0.tar.gz 78825 BLAKE2B f8228502944e6fc50412533c0c3f6d03fe7538dae8e1c42dd01d6b4419ef165f98125712e48d5c5b7f0d7eced36b6a84a69b9da549fe5e57effcba652f78faec SHA512 10d0344e05a142b3edadc970dd5cebc5eada1f638a599ca0f566c00149d67626c7fa1bbe668a56bc93048669df3af266c581f4872bf5756a4cc526f4b831dfc1
EBUILD pyjwt-2.8.0.ebuild 824 BLAKE2B c95cfd39533ee284daeb434434998cffa02dc99a4021abef68f0dffb4de98bdd3279c1f78634f978e98ca667d83741bee7d921226ad7ec31a56343e74018b94e SHA512 116febe73a8d8dceff3487f2947407e2938b34bc1354e14fb106769b282d283dba0d3a94b28e08e9ba2c584c80beedfb5598fd819b1545947f50f6b173062dc6
+EBUILD pyjwt-2.9.0.ebuild 810 BLAKE2B 0575f7c36a5dd187ecc59dd71f211e7aadd1ce82c8d4f3d1a2fc5ac030835510b2882b020a95e78b1847d71c4dd064c532fece03bec74868f48bb016224d0120 SHA512 00cb890e8d19f1d4480b93634fdedbe131aed8e22c734591bb3eed70e37b7af39fbc3460c7f0e370c09c61a2d06e847b4bbef7c75ffa3966a761ebcbdbec02db
MISC metadata.xml 450 BLAKE2B e0a5244140aed7eb1dbc7d1bedf41b64f999ada11a82d5a7c3720501d824c789590e5339d5855fa4d0f96ff1b572e86af41859f8f14105f2f9b1a715d9d71d87 SHA512 83bce7997e724867cf1962ce75d8bb8e7a4e7a8dcdb42b95d9d323ca3a3ea4584020d4b700885e1afcb753d4fcacee23ec7b25066e93c0ac5eb614f65d140f29
diff --git a/dev-python/pyjwt/pyjwt-2.9.0.ebuild b/dev-python/pyjwt/pyjwt-2.9.0.ebuild
new file mode 100644
index 000000000000..d7c6984ef15b
--- /dev/null
+++ b/dev-python/pyjwt/pyjwt-2.9.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN="PyJWT"
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="JSON Web Token implementation in Python"
+HOMEPAGE="
+ https://github.com/jpadilla/pyjwt/
+ https://pypi.org/project/PyJWT/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ !dev-python/python-jwt
+"
+BDEPEND="
+ test? (
+ >=dev-python/cryptography-3.4.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_jwks_client.py::TestPyJWKClient::test_get_jwt_set_sslcontext_default
+)
+
+pkg_postinst() {
+ optfeature "cryptography" dev-python/cryptography
+}