summaryrefslogtreecommitdiff
path: root/dev-python/pyjsparser/pyjsparser-2.7.1_p20190421-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyjsparser/pyjsparser-2.7.1_p20190421-r1.ebuild')
-rw-r--r--dev-python/pyjsparser/pyjsparser-2.7.1_p20190421-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyjsparser/pyjsparser-2.7.1_p20190421-r1.ebuild b/dev-python/pyjsparser/pyjsparser-2.7.1_p20190421-r1.ebuild
new file mode 100644
index 000000000000..8b2a6183601a
--- /dev/null
+++ b/dev-python/pyjsparser/pyjsparser-2.7.1_p20190421-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=5465d037b30e334cb0997f2315ec1e451b8ad4c1
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast javascript parser based on esprima.js"
+HOMEPAGE="https://github.com/PiotrDabkowski/pyjsparser/
+ https://pypi.org/project/pyjsparser/"
+SRC_URI="https://github.com/PiotrDabkowski/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+RESTRICT="!test? ( test )"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc x86"
+IUSE="test"
+
+BDEPEND="
+ test? (
+ dev-python/js2py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" ./test_runner.py || die "tests failed with ${EPYTHON}"
+}