summaryrefslogtreecommitdiff
path: root/dev-python/pyicu/pyicu-2.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyicu/pyicu-2.8.ebuild')
-rw-r--r--dev-python/pyicu/pyicu-2.8.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyicu/pyicu-2.8.ebuild b/dev-python/pyicu/pyicu-2.8.ebuild
new file mode 100644
index 000000000000..4c203aac2bbc
--- /dev/null
+++ b/dev-python/pyicu/pyicu-2.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="Python bindings for dev-libs/icu"
+HOMEPAGE="
+ https://gitlab.pyicu.org/main/pyicu/
+ https://pypi.org/project/PyICU/"
+SRC_URI="
+ https://gitlab.pyicu.org/main/pyicu/-/archive/v${PV}/${MY_P}.tar.bz2"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/icu:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? ( dev-python/six[${PYTHON_USEDEP}] )"
+
+DOCS=( CHANGES CREDITS README.md )
+
+distutils_enable_tests pytest