summaryrefslogtreecommitdiff
path: root/dev-python/pygresql/pygresql-5.2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygresql/pygresql-5.2.2.ebuild')
-rw-r--r--dev-python/pygresql/pygresql-5.2.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pygresql/pygresql-5.2.2.ebuild b/dev-python/pygresql/pygresql-5.2.2.ebuild
new file mode 100644
index 000000000000..709e1ceeafe2
--- /dev/null
+++ b/dev-python/pygresql/pygresql-5.2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 9.{5..6} {10..13} )
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 postgres
+
+MY_P="PyGreSQL-${PV}"
+
+DESCRIPTION="A Python interface for the PostgreSQL database"
+HOMEPAGE="https://pygresql.org/"
+SRC_URI="mirror://pypi/P/PyGreSQL/${MY_P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND="${POSTGRES_DEP}"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}"/${PN}-5.2-CFLAGS.patch )
+
+python_install_all() {
+ local DOCS=( docs/*.rst docs/community/* docs/contents/tutorial.rst )
+
+ distutils-r1_python_install_all
+}