summaryrefslogtreecommitdiff
path: root/dev-python/pyglet
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyglet')
-rw-r--r--dev-python/pyglet/Manifest4
-rw-r--r--dev-python/pyglet/metadata.xml3
-rw-r--r--dev-python/pyglet/pyglet-1.5.3.ebuild63
3 files changed, 69 insertions, 1 deletions
diff --git a/dev-python/pyglet/Manifest b/dev-python/pyglet/Manifest
index 6d763a6af795..47177a432490 100644
--- a/dev-python/pyglet/Manifest
+++ b/dev-python/pyglet/Manifest
@@ -1,3 +1,5 @@
DIST pyglet-1.2.4.tar.gz 2122017 BLAKE2B 6e5e24ec78e24b9a9c8e9627791ede93d740c1af7af0176c6f75409c76981fa16752bbe14c9b5ec871438f5468b3587e7ce12194241d94ab3731d46cbbe395f1 SHA512 70cd781936db8c8c156499e524ee73520bc90c19461074264abd62a4854307ef090af5faba521686f247fb4cbee552a428892f59a5b382429acfc000f4c2e22d
+DIST pyglet-1.5.3.tar.gz 6356079 BLAKE2B 517b196eff334d572d4db181ce0480c3af8e2bc4a92e23e1fd7c335aedebe3afa493eb3f4745d8daffc3c7d930b9e333075014d2ba5d4303f4691c490a09f252 SHA512 12e7189272b9ab3b4bd3d713d0e979cfc1d76200fc8454b31573fca29b179f99242c34a1adb7a1c2fabb7b950cc3006cfcd8b188eb2c50ae95cca95b0e15582c
EBUILD pyglet-1.2.4.ebuild 1033 BLAKE2B 4f8c751ac08ea2d5d6fc1ebe1d74143311a2fe8834c7ab447f9fd42e606371f463f39b7b6e37e2b3767213b2bd1455cdfe06c66c2020946a656fe00312d2d4db SHA512 1bfb9ffc5e0db92f8b01288989ba8726a27e1316168a3e8d836a601e379ac4c5d57665e002863da205ed1e7768b24987423ac24c88dab3b34082a6d5aa1e3169
-MISC metadata.xml 893 BLAKE2B b2c9d0381d98ba205738e1fee69cb1a8952060c5d0095d134d84136af35fd38da8f81cca964a1ad748e615cb9c443b18f53a31f436a8356c83725423e16e8b64 SHA512 2bf1d8f350103309d98bda2834337acf488726e3ee141509f3423c46695c87d2a61557dec3d3c0e523815e09fd3d02eb3411779b4ce2fac05b83425401480269
+EBUILD pyglet-1.5.3.ebuild 1246 BLAKE2B 5beebbbfde2a30bb8e1fa10a06b9ecc2521be8786bf0c3d43ca6c6d03b0872995a4cfd8eee1b0594c5fdf22f149bbf9741fe5cde7cc06e3ad74ce66e1af8983c SHA512 d497a9119656bf33d013a2b7fdd0b7646ecf63f267f8b046a5d436d672bff01a9be76a57d55060ddd6080c90bf2b44aea7cd48e7c067722a605e253b4efa9a09
+MISC metadata.xml 996 BLAKE2B 74fda944aaa3954eafb31e21741f8cb599c9f8bff46c662a598cb384da9770d3160302b37ce8cbe9ddbc7dfe63c594614783afa568ab4be5e73db502fdc3a095 SHA512 a13a1aa2134de7bc7e007f81540631623c5a3fc1f5bfd4b6f7bc744eff8cc037da321292aa968184d324099dbfd87f608d7c0a2aeea90707c27aee5532a1fe15
diff --git a/dev-python/pyglet/metadata.xml b/dev-python/pyglet/metadata.xml
index 85c37d9142f7..c4ade21967f9 100644
--- a/dev-python/pyglet/metadata.xml
+++ b/dev-python/pyglet/metadata.xml
@@ -8,6 +8,9 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <use>
+ <flag name="image">Enable support for image formats other than PNG and BMP</flag>
+ </use>
<longdescription lang="en">This library provides an object-oriented programming interface
for developing games and other visually-rich applications with Python.
pyglet has virtually no external dependencies. For most applications
diff --git a/dev-python/pyglet/pyglet-1.5.3.ebuild b/dev-python/pyglet/pyglet-1.5.3.ebuild
new file mode 100644
index 000000000000..c583e7548a71
--- /dev/null
+++ b/dev-python/pyglet/pyglet-1.5.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1 virtualx xdg-utils
+
+DESCRIPTION="Cross-platform windowing and multimedia library for Python"
+HOMEPAGE="http://www.pyglet.org/"
+SRC_URI="https://github.com/pyglet/pyglet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples image +sound test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/opengl
+ image? ( || (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ x11-libs/gtk+:2
+ ) )
+ sound? ( || (
+ media-libs/openal
+ media-sound/pulseaudio
+ ) )
+"
+# ffmpeg? ( media-libs/avbin-bin )
+
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+# pyglet.gl.glx_info.GLXInfoException: pyglet requires an X server with GLX
+# Other tests fail or stall for unknown reasons.
+RESTRICT=test
+
+DOCS=(
+ DESIGN
+ NOTICE
+ README.md
+ RELEASE_NOTES
+)
+
+python_test() {
+ xdg_environment_reset
+ run_in_build_dir virtx pytest -v "${S}"/tests
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}