summaryrefslogtreecommitdiff
path: root/dev-python/pygit2/pygit2-1.6.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygit2/pygit2-1.6.1-r2.ebuild')
-rw-r--r--dev-python/pygit2/pygit2-1.6.1-r2.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/pygit2/pygit2-1.6.1-r2.ebuild b/dev-python/pygit2/pygit2-1.6.1-r2.ebuild
deleted file mode 100644
index fa7f6c1fbf6e..000000000000
--- a/dev-python/pygit2/pygit2-1.6.1-r2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for libgit2"
-HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.org/project/pygit2/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- =dev-libs/libgit2-1.2*:=
- dev-python/cached-property[${PYTHON_USEDEP}]
- >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- local PATCHES=(
- "${FILESDIR}"/${P}-libgit2-1.2.0.patch
- )
-
- distutils-r1_src_prepare
-
- # unconditionally prevent it from using network
- sed -i -e '/has_network/s:True:False:' test/utils.py || die
-
- # we need to move them away to prevent pytest from forcing '..'
- # for imports
- mkdir hack || die
- mv test hack/ || die
- ln -s hack/test test || die
-}
-
-python_test() {
- epytest hack/test
-}