summaryrefslogtreecommitdiff
path: root/dev-python/pygccxml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygccxml')
-rw-r--r--dev-python/pygccxml/Manifest2
-rw-r--r--dev-python/pygccxml/pygccxml-3.0.2.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pygccxml/Manifest b/dev-python/pygccxml/Manifest
index 71af99c717b6..a464247674b2 100644
--- a/dev-python/pygccxml/Manifest
+++ b/dev-python/pygccxml/Manifest
@@ -2,6 +2,8 @@ AUX pygccxml-2.4.0-doc.patch 798 BLAKE2B f062375f40ada000fd266f50d6fdf3ab70ef744
AUX pygccxml-2.6.1-xml_generator.patch 207 BLAKE2B f4a4081edf2adf520bd2bd9739528f6090bae3b0ca0a0e137d29c528a2fe9bfa8be854e71ade91657f043f66aa899f1ff9ad7f10ff3e3df7ea323efa101cf8ec SHA512 ac90d4d3a6123f29152c091616f5456741acaf859f0d5a360dc851a99a4dea5d315e8a80735641166259edbe2ee0dffe19b6aa986a10f93cdecee3db0ee099c0
DIST pygccxml-2.6.1.gh.tar.gz 3154561 BLAKE2B 95fb9df63f4175eab707211cb14d178437928ddad76eeb416d8cf4a48b29c211d80ba55533deb0a12e6bad4435df9bf82a1321b37cdc8db39d217f2995d1215e SHA512 b0ccd12b50d93287189fa86be6e11f44e28869045e6d7f6f84f34220cea642fc267eee150fe544bb54839b7f467f64af4a6025c84b94df7793645f2d444ae60d
DIST pygccxml-3.0.0.gh.tar.gz 3155557 BLAKE2B a485f5b25d724c0c67a4a6108b298ecf5da9bd3fd365f513ce424239d3e94d76a88cdc1b7839fd69b5dc897a3e7e4f86721a8411ca9c6faa37da9edae509d387 SHA512 061150cabbe3eb8853dcd48be91d741f7af405f6682bd6a6000e83bf5c5da8ed572467131f98234158f86deac6c8881736fa47b6a89149edbe10c00729e863b5
+DIST pygccxml-3.0.2.gh.tar.gz 3156023 BLAKE2B add33e230db83cadd5fd394e7e65c8815227abb3d5f86e76c54bcbc13ba52ffa55698d98785802ac51d9396f009972a093476e489280548469d5000aff8aa010 SHA512 d94b9175bd88bc92d039b758e2052d3c72e510cc381cbd974d670ff6cc06f80f7918bcd8da06efd82729d294e0972cee60690c7b0e24ab2c62a53c366bae9fb5
EBUILD pygccxml-2.6.1.ebuild 1682 BLAKE2B 7ba9f54bfa2a3be624e2f6ad9bc79f8eccffbea02c83681b65fe15db2576ec2e7e6f61537490d29eda0faef2b8e50786ef6eda4d34bf58f99c1b5606afc7feb8 SHA512 c9f1fac7b35b1349e190617b278f1ef92f4bf7bc49c0b190d2b55e39fb809605a75a43619e11f0730fe7df0cdfd27273a0959b9807b7228e405e0ec0cbe05224
EBUILD pygccxml-3.0.0.ebuild 840 BLAKE2B ff628aa9037331d63cc775a4b6b6775f9cd74e75afdb3f039471968d2bc0a26736fdeb3ed3e02ec93a85b7d4ac97de6cf067f80ef9fe50ea6895a6ee11664456 SHA512 59ff75b244bf18cf2b9649febef942cb1346826d46ee34e07ed39e82b798c69bcd4681b21a5e89ce68960a28172ceaf8e652936d132db9feac9e85024b2b9754
+EBUILD pygccxml-3.0.2.ebuild 840 BLAKE2B ff628aa9037331d63cc775a4b6b6775f9cd74e75afdb3f039471968d2bc0a26736fdeb3ed3e02ec93a85b7d4ac97de6cf067f80ef9fe50ea6895a6ee11664456 SHA512 59ff75b244bf18cf2b9649febef942cb1346826d46ee34e07ed39e82b798c69bcd4681b21a5e89ce68960a28172ceaf8e652936d132db9feac9e85024b2b9754
MISC metadata.xml 554 BLAKE2B 27017dc7cae6aacbe62f9ba64896e0a247371844b0baab86c5c1b1673771b888e2043a4486863857b565ed18a7928c500c07b6c6dc4f1f50494e680367928aca SHA512 eb46746c8d9b3341d8057a457785ad0c3b34ba26ca941496bc5c37f767c7472a2ed2bb5aafe06f5b677710f969b9a9229d8c24cd3dcdd30624168765bc89e3b7
diff --git a/dev-python/pygccxml/pygccxml-3.0.2.ebuild b/dev-python/pygccxml/pygccxml-3.0.2.ebuild
new file mode 100644
index 000000000000..a9410da95bbd
--- /dev/null
+++ b/dev-python/pygccxml/pygccxml-3.0.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A specialized XML reader to navigate C++ declarations"
+HOMEPAGE="
+ https://github.com/CastXML/pygccxml/
+ https://pypi.org/project/pygccxml/
+"
+SRC_URI="
+ https://github.com/CastXML/pygccxml/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/castxml
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+EPYTEST_DESELECT=(
+ tests/test_smart_pointer.py
+)
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/${PN}-2.4.0-doc.patch"
+ )
+
+ distutils-r1_python_prepare_all
+}