summaryrefslogtreecommitdiff
path: root/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild')
-rw-r--r--dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild29
1 files changed, 12 insertions, 17 deletions
diff --git a/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild b/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild
index 2c7b47dbd37e..dc01aea24405 100644
--- a/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild
+++ b/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=6
PYTHON_COMPAT=( python{2_7,3_5,3_6} )
inherit distutils-r1
@@ -14,31 +14,26 @@ SRC_URI="http://www.renpy.org/dl/${PV}/${PYSDL}-for-renpy-${PV}.tar.gz"
LICENSE="LGPL-2.1 ZLIB"
SLOT="0"
-KEYWORDS="amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE=""
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
-"
-DEPEND="
+RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
- media-libs/libpng:0
- media-libs/libsdl2[video]
- media-libs/sdl2-image[png,jpeg]
- >=media-libs/sdl2-mixer-2.0.2
- media-libs/sdl2-ttf
- virtual/jpeg:62
-"
-RDEPEND="${DEPEND}"
+ media-libs/libpng:0=
+ media-libs/libsdl2:=[video]
+ media-libs/sdl2-image:=[png,jpeg]
+ media-libs/sdl2-mixer:=
+ media-libs/sdl2-ttf:=
+ virtual/jpeg:0"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]"
S=${WORKDIR}/${PYSDL}-for-renpy-${PV}
-PATCHES=( "${FILESDIR}/pygame_sdl2-6.99.12.4-mixer.patch" )
-
# PyGame distribution for this version has some pregenerated files;
# we need to remove them
python_prepare_all()
{
- rm -r "${S}"/gen{,3} || die
+ rm -r gen{,3} || die
distutils-r1_python_prepare_all
}