summaryrefslogtreecommitdiff
path: root/dev-python/pygal/pygal-2.4.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygal/pygal-2.4.0-r2.ebuild')
-rw-r--r--dev-python/pygal/pygal-2.4.0-r2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/pygal/pygal-2.4.0-r2.ebuild b/dev-python/pygal/pygal-2.4.0-r2.ebuild
index c67f4dee8145..dad973603437 100644
--- a/dev-python/pygal/pygal-2.4.0-r2.ebuild
+++ b/dev-python/pygal/pygal-2.4.0-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="xml(+)"
inherit distutils-r1
@@ -24,7 +24,10 @@ RDEPEND="
BDEPEND="
test? ( dev-python/pyquery[${PYTHON_USEDEP}] )"
-PATCHES=( "${FILESDIR}/${PV}-fix-tests.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-fix-tests.patch"
+ "${FILESDIR}/${P}-fix-py3.10.patch"
+)
# CHANGELOG is a symlink to docs/changelog.rst
DOCS=( docs/changelog.rst README.md )