summaryrefslogtreecommitdiff
path: root/dev-python/pyflakes
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyflakes')
-rw-r--r--dev-python/pyflakes/Manifest3
-rw-r--r--dev-python/pyflakes/files/pyflakes-3.0.1-python3.11.patch38
-rw-r--r--dev-python/pyflakes/pyflakes-3.0.1-r1.ebuild25
3 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/pyflakes/Manifest b/dev-python/pyflakes/Manifest
index db75507fa062..bd84124528c3 100644
--- a/dev-python/pyflakes/Manifest
+++ b/dev-python/pyflakes/Manifest
@@ -1,6 +1,3 @@
-AUX pyflakes-3.0.1-python3.11.patch 1531 BLAKE2B c68512c3bf6c1d3eebbaead6bf47274731de46c73a830b8ad48655a7fbf1f5420ce3a9f2d5638c459979d94d2ede38b3f07d00cfd2c4b25ce9d44b78ded33fb7 SHA512 d1ff78e686be4c4222ace7cf0af950f9926a3d2185fdb46f7294fce4779c062016c5a0a20ac2d025c329c24dc4a55482a1298565e4331240b8baab9bbc6c529b
-DIST pyflakes-3.0.1.tar.gz 63554 BLAKE2B 992dc4c81204c9ae2fd44744452e76a11209552edaef930edb14b7ba4763720cd1c0c0cd148fa7edd474b33aa529d8ec28f7f35a2b02b707d58cf70243fc13a9 SHA512 10ffe2b92f3885d40578452423a93609f8546b2392997bdbc3f64ca0094516ce6b8449e5d3675bda5fdbc16190c89be23609559fc4cd4f1c97e6af032226d7b7
DIST pyflakes-3.1.0.tar.gz 63636 BLAKE2B 89e5fae6bba9efc820e348ddac37fd8590478c64363a5f295cc620ebbc7b51d4d51e0cff30b6a54ee573612e5309d7fff9462bc31c9e89c34cf7cdbecffabd30 SHA512 6277eaa82a3d94f8052b3da865cfcc8e99846738b5869fca1be92bb5b9a4db0088859d811da565200e640ad0555d46e0ebcaf831cd422b84304514592270b02e
-EBUILD pyflakes-3.0.1-r1.ebuild 612 BLAKE2B 6a6632bb932d48e8601ba73f2d40b880d5529bbfbcf51139e538cf48abb39b5dfac5f21172074ad410bbab8be43e352f85b5d8d27e0c8b1380e351f222ca2d70 SHA512 5f7ed4864794d85a9941568fc9324d400e861cdec6f3f51100bc27e2375dd69c0fa1d03c9f24d9cf89e61cef33075562fa4d6df806b9cdfada6675a9de22d1c8
EBUILD pyflakes-3.1.0.ebuild 957 BLAKE2B e7e4ad272e514d4ee5c95aa28c2447e34dd7f293b5593c47838eecbc4091353a54a1bf7759fae65d91972ea643004a23f16d5c4a4fda46713d16257e065ecfab SHA512 2915e2c33df051b73083e986df506c988db1fb19e265318b36a02a684927b700a8e9cfa52272ab189623121f865f653ba4bccee715b415e6065c7624a9d6a1f2
MISC metadata.xml 763 BLAKE2B e15bc4240e0cc54bd0d7ecca523bcc43c5ae6ebd4f195815f7b2c3494e0366f1cc6feadbc63fce82390ed414e8f52a7bdf15f5c56909ab39879814ff1b178558 SHA512 bb8e0b6f746c99e5185a8bca736f0af36068ae0de45d1bde9663f0e732770366ac20f2116ddd9d7a85239146cf5d7b8fbbfc5c225d7bca4650001f86468a0142
diff --git a/dev-python/pyflakes/files/pyflakes-3.0.1-python3.11.patch b/dev-python/pyflakes/files/pyflakes-3.0.1-python3.11.patch
deleted file mode 100644
index db804f42c775..000000000000
--- a/dev-python/pyflakes/files/pyflakes-3.0.1-python3.11.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-https://github.com/PyCQA/pyflakes/commit/836631f2f73d45baa4021453d89fc9fd6f52be58
-https://bugs.gentoo.org/909554
-
-From 836631f2f73d45baa4021453d89fc9fd6f52be58 Mon Sep 17 00:00:00 2001
-From: Anthony Sottile <asottile@umich.edu>
-Date: Mon, 12 Jun 2023 21:00:45 -0400
-Subject: [PATCH] fix error reporter and testsuite in 3.11.4+ (#775)
-
---- a/pyflakes/reporter.py
-+++ b/pyflakes/reporter.py
-@@ -56,8 +56,9 @@ def syntaxError(self, filename, msg, lineno, offset, text):
- else:
- line = text.splitlines()[-1]
-
-+ # lineno might be None if the error was during tokenization
- # lineno might be 0 if the error came from stdin
-- lineno = max(lineno, 1)
-+ lineno = max(lineno or 0, 1)
-
- if offset is not None:
- # some versions of python emit an offset of -1 for certain encoding errors
---- a/pyflakes/test/test_api.py
-+++ b/pyflakes/test/test_api.py
-@@ -621,8 +621,12 @@ def test_misencodedFileUTF16(self):
- x = "%s"
- """ % SNOWMAN).encode('utf-16')
- with self.makeTempFile(source) as sourcePath:
-- self.assertHasErrors(
-- sourcePath, [f"{sourcePath}: problem decoding source\n"])
-+ if sys.version_info < (3, 11, 4):
-+ expected = f"{sourcePath}: problem decoding source\n"
-+ else:
-+ expected = f"{sourcePath}:1: source code string cannot contain null bytes\n" # noqa: E501
-+
-+ self.assertHasErrors(sourcePath, [expected])
-
- def test_checkRecursive(self):
- """
diff --git a/dev-python/pyflakes/pyflakes-3.0.1-r1.ebuild b/dev-python/pyflakes/pyflakes-3.0.1-r1.ebuild
deleted file mode 100644
index 4060d6d1f972..000000000000
--- a/dev-python/pyflakes/pyflakes-3.0.1-r1.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Passive checker for Python programs"
-HOMEPAGE="
- https://github.com/PyCQA/pyflakes/
- https://pypi.org/project/pyflakes/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-
-PATCHES=(
- "${FILESDIR}"/${P}-python3.11.patch
-)
-
-distutils_enable_tests unittest