summaryrefslogtreecommitdiff
path: root/dev-python/pydyf/pydyf-0.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pydyf/pydyf-0.1.1.ebuild')
-rw-r--r--dev-python/pydyf/pydyf-0.1.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pydyf/pydyf-0.1.1.ebuild b/dev-python/pydyf/pydyf-0.1.1.ebuild
new file mode 100644
index 000000000000..0ecfdfd4412d
--- /dev/null
+++ b/dev-python/pydyf/pydyf-0.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A low-level PDF generator"
+HOMEPAGE="
+ https://pypi.org/project/pydyf/
+ https://github.com/CourtBouillon/pydyf/"
+SRC_URI="
+ https://github.com/CourtBouillon/pydyf/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ app-text/ghostscript-gpl
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}