summaryrefslogtreecommitdiff
path: root/dev-python/pydotplus
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pydotplus')
-rw-r--r--dev-python/pydotplus/Manifest4
-rw-r--r--dev-python/pydotplus/files/pydotplus-2.0.2-tests.patch17
-rw-r--r--dev-python/pydotplus/metadata.xml12
-rw-r--r--dev-python/pydotplus/pydotplus-2.0.2-r1.ebuild32
4 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/pydotplus/Manifest b/dev-python/pydotplus/Manifest
deleted file mode 100644
index d366be517ca7..000000000000
--- a/dev-python/pydotplus/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX pydotplus-2.0.2-tests.patch 907 BLAKE2B 387823545ea3b1372b6584a4b2daca756eb21d81487e3749309c155e37b21171e8e624d54caecc0b356a1456446a4e3b8340b5fc233301bc270fb3056571a601 SHA512 21dd557a0a94d6ad0e4932e01a97a450d76c0f7bcceab870b0ba60a2b96c711ab139fc682ca2a20da4c68b49fe37577763639bb77b9fbe28c7fa1281f2e5bb4b
-DIST pydotplus-2.0.2.tar.gz 278677 BLAKE2B 879271ba7e2104134a71caef7676082420770dcdb34aeabfe76232ad8f9774d3e90a9f7ca5fb407a7a4e8e0c4e5e01824bd0d5936fe77554cc661839fcc0dc7b SHA512 6f06a1f284401123a4514f9e9a4974dee8dc8d01e6b7c40a797fb70eed22b99fe774272f8b106b5632a33f524b356349fe1ff9633101ff61ef2fc3fe69d641ac
-EBUILD pydotplus-2.0.2-r1.ebuild 581 BLAKE2B 723400bb8b083f7a0e247b184a3424a39a4291212497bfa8cd7c1464478f55263084ebf7cd508b16f5a38343b517d9a8d4bd1304f77dc7e334f3d875b25df968 SHA512 0a5a2d9b6d772cf0ac853fb7f38b540b5a0b2a0a0ed6bdb948554bb0d2715e03bb8ccd4a42ea38efe6b050cdaa023330dbfe0107f8911eb983def2b330d4d834
-MISC metadata.xml 414 BLAKE2B 02e990f63d70819393d8859bc20f411e4791678e376cf84e61b49ec1bb2c68ccbb6202c6a25675d89a3eb81067a06f972df5728aa35fc3db0837fcd67546b531 SHA512 ed6842b00444c3021ac79f043d67f78a3eb5acd4b0f4e2828cf25885d15b32ff2eb0d97c304fc8c4a5ae63340a142c5835933db410547b5abfe6a0dd0e6670f3
diff --git a/dev-python/pydotplus/files/pydotplus-2.0.2-tests.patch b/dev-python/pydotplus/files/pydotplus-2.0.2-tests.patch
deleted file mode 100644
index 65d9c5f9f45b..000000000000
--- a/dev-python/pydotplus/files/pydotplus-2.0.2-tests.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/test/pydot_unittest.py
-+++ b/test/pydot_unittest.py
-@@ -142,6 +142,7 @@ class TestGraphAPI(unittest.TestCase):
- self.assertEqual(g2.get_edges()[0].get_source(), node1)
- self.assertEqual(g2.get_edges()[0].get_destination(), node2)
-
-+ @unittest.skip(reason="Known to fail on Gentoo, reported upstream: https://github.com/carlos-jenkins/pydotplus/issues/22")
- def test_graph_with_shapefiles(self):
-
- shapefile_dir = os.path.join(TEST_DIR, 'from-past-to-future')
-@@ -225,6 +226,7 @@ class TestGraphAPI(unittest.TestCase):
- def test_my_regression_tests(self):
- self._render_and_compare_dot_files(MY_REGRESSION_TESTS_DIR)
-
-+ @unittest.skip(reason="Known to fail on Gentoo, reported upstream: https://github.com/carlos-jenkins/pydotplus/issues/22")
- def test_graphviz_regression_tests(self):
- self._render_and_compare_dot_files(REGRESSION_TESTS_DIR)
diff --git a/dev-python/pydotplus/metadata.xml b/dev-python/pydotplus/metadata.xml
deleted file mode 100644
index 4762ce100175..000000000000
--- a/dev-python/pydotplus/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription lang="en">
- PyDotPlus is an improved version of the old pydot project that provides
- a Python Interface to Graphviz’s Dot language.
- </longdescription>
- <upstream>
- <remote-id type="pypi">pydotplus</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pydotplus/pydotplus-2.0.2-r1.ebuild b/dev-python/pydotplus/pydotplus-2.0.2-r1.ebuild
deleted file mode 100644
index 71c2ab22addc..000000000000
--- a/dev-python/pydotplus/pydotplus-2.0.2-r1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Improved version of the old pydot project"
-HOMEPAGE="https://pydotplus.readthedocs.org/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/pyparsing[${PYTHON_USEDEP}]
- media-gfx/graphviz
-"
-
-distutils_enable_tests unittest
-
-PATCHES=(
- "${FILESDIR}"/${P}-tests.patch
-)
-
-python_test() {
- cd test || die
- "${EPYTHON}" pydot_unittest.py || die
-}