summaryrefslogtreecommitdiff
path: root/dev-python/pydocstyle/pydocstyle-6.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pydocstyle/pydocstyle-6.0.0.ebuild')
-rw-r--r--dev-python/pydocstyle/pydocstyle-6.0.0.ebuild30
1 files changed, 0 insertions, 30 deletions
diff --git a/dev-python/pydocstyle/pydocstyle-6.0.0.ebuild b/dev-python/pydocstyle/pydocstyle-6.0.0.ebuild
deleted file mode 100644
index e434a8ff0cf6..000000000000
--- a/dev-python/pydocstyle/pydocstyle-6.0.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Python docstring style checker"
-HOMEPAGE="https://github.com/PyCQA/pydocstyle/"
-SRC_URI="https://github.com/PyCQA/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 sparc x86 ~x64-macos"
-
-RDEPEND="dev-python/snowballstemmer[${PYTHON_USEDEP}]"
-
-distutils_enable_tests --install pytest
-# Requires network to lookup github issues
-#distutils_enable_sphinx docs dev-python/sphinx_rtd_theme dev-python/sphinxcontrib-issuetracker
-
-src_prepare() {
- # no, seriously, you don't need to install it yourself
- sed -i -e '/pip/d' src/tests/test_integration.py || die
-
- distutils-r1_src_prepare
-}