summaryrefslogtreecommitdiff
path: root/dev-python/pydispatcher/pydispatcher-2.0.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pydispatcher/pydispatcher-2.0.5.ebuild')
-rw-r--r--dev-python/pydispatcher/pydispatcher-2.0.5.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/pydispatcher/pydispatcher-2.0.5.ebuild b/dev-python/pydispatcher/pydispatcher-2.0.5.ebuild
deleted file mode 100644
index e37ed6656def..000000000000
--- a/dev-python/pydispatcher/pydispatcher-2.0.5.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 vcs-snapshot
-
-MY_PN="PyDispatcher"
-
-DESCRIPTION="Multi-producer-multi-consumer signal dispatching mechanism"
-HOMEPAGE="http://pydispatcher.sourceforge.net/ https://pypi.org/project/PyDispatcher/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
-IUSE="doc examples"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-
-python_compile_all() {
- if use doc; then
- pushd docs/pydoc/ > /dev/null
- "${PYTHON}" builddocs.py || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-python_test() {
- "${PYTHON}" -m unittest discover
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/pydoc/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}