summaryrefslogtreecommitdiff
path: root/dev-python/pycurl
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycurl')
-rw-r--r--dev-python/pycurl/Manifest2
-rw-r--r--dev-python/pycurl/pycurl-7.45.5.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/pycurl/Manifest b/dev-python/pycurl/Manifest
index 1900bf57ebd8..25e0fbc27306 100644
--- a/dev-python/pycurl/Manifest
+++ b/dev-python/pycurl/Manifest
@@ -1,5 +1,7 @@
DIST pycurl-7.45.3.tar.gz 236470 BLAKE2B 690e49f92f569352e26d95a0fa58508c4e96c845c7e3ae1169b8bc55036902f64859987880565217df56a57031dc2775e3c6979b4cfdf8a8c9a94c67ae94cb79 SHA512 12a55070602a1fd22b160ad582a4001bdd28531d2b2ccd365ff0136bc13dd23af80b19488bdbbc60a902a3a362b64383b9ae6acce6ed328c74dcffc8a6a3f4ad
DIST pycurl-7.45.4.tar.gz 238427 BLAKE2B dac2b950fd53156511f358d51fc5b5b690cd56880a5e47becef6bc61060f68a7948c2cd80cfdb919378addf7af5a0e45caf8fc375355ec0287bd112f5b531a9b SHA512 bf4012f8a97bde5864e31ddfe310c8de52dc304215ff054658c944337bb3f6dc248c051d92f0ee90d1701ab057b12068c5632bacdadb94677595c8a522c3a1db
+DIST pycurl-7.45.5.tar.gz 239351 BLAKE2B 6246a17e4a2e5546e0ec6a4557165a3d4b8f211945bdc0cd57170bdc1782d5fdded8e5cf52a9b1d56f3cb7182b13bfe1882147f6439bbe601d7411c190fb1f8e SHA512 ca42570c0c92c4e6e8a4a41158bc5db771dedee65e1f3b18410d69d2e4bda5859109b60b3d593dd2afaf3b2398003fa4dcc2fbe2621571457b0aded4aae262c6
EBUILD pycurl-7.45.3.ebuild 2950 BLAKE2B 5aa448cbe1d3fa75b9610b396132063be7028edc89d073580926e0a0698781ad8f08d024325e194975a7c346e7a0bed5fc590d18a4064a5a48fa781b0326beaf SHA512 210207f890211edfd7500d01dc3470a0f88045c31ffac73c02b463e98029618b72e3e0409f305749d62c7ceae9a5c115d18a77324d5b35133a7ff512bb6ab0cd
EBUILD pycurl-7.45.4.ebuild 2356 BLAKE2B 590198a328525114ef1c6b9ae4e8cef298992d158ae0ddb6809645b8957d3be79e73f1276c68c8f69e4a76e54017f76d61279b30264f27ef622482dd1c6a5075 SHA512 3fcdc56b3f0ba0271258bb333e8e3f2d5f634819fcf50df0902632558f391111bb3e52a5f26949a96d81680b7d08101acc439e21e7bcfc745fccb15265559101
+EBUILD pycurl-7.45.5.ebuild 2361 BLAKE2B a680721e7e97452a975adf7fed8d3bd80c68afae1bb067cdc7223c03cc4a5fb54829c803b9ee9887dd401a0c1df4529056d451c859e71f86e5cae609ce6e3fe7 SHA512 3a52499e51fd90c3be95fefdc2653e22405c7b128baf05abdbef7dc09da95858691cbf3bfdfbd07e848690d0cbf593235b205b33019567a87325def613197b5c
MISC metadata.xml 1100 BLAKE2B dfc7fe054c7cc34c61bf58fef0378df304a539c28cbc0dff4ffff65ccc8892c38aaf1e275885fc54d2854d9acc6b382947038041f815b5941859be7cfe75523f SHA512 f1de0dccd625ae0b02ff9a55cbc1bbf7944faa24dba28ffd711c728001f180afa598a255132aea860ad616637325cdc653577af531b1a954a3994e8902c774aa
diff --git a/dev-python/pycurl/pycurl-7.45.5.ebuild b/dev-python/pycurl/pycurl-7.45.5.ebuild
new file mode 100644
index 000000000000..412b1153e67b
--- /dev/null
+++ b/dev-python/pycurl/pycurl-7.45.5.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi toolchain-funcs
+
+DESCRIPTION="Python bindings for curl/libcurl"
+HOMEPAGE="
+ http://pycurl.io/
+ https://github.com/pycurl/pycurl/
+ https://pypi.org/project/pycurl/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="curl_ssl_gnutls +curl_ssl_openssl examples ssl"
+
+# Depend on a curl with curl_ssl_* USE flags.
+# libcurl must not be using an ssl backend we do not support.
+# If the libcurl ssl backend changes pycurl should be recompiled.
+# If curl uses gnutls, depend on at least gnutls 2.11.0 so that pycurl
+# does not need to initialize gcrypt threading and we do not need to
+# explicitly link to libgcrypt.
+DEPEND="
+ >=net-misc/curl-7.25.0-r1:=[ssl=]
+ ssl? (
+ net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-)]
+ curl_ssl_gnutls? ( >=net-libs/gnutls-2.11.0:= )
+ curl_ssl_openssl? ( dev-libs/openssl:= )
+ )
+"
+
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),http2]
+ )
+"
+
+: ${EPYTEST_TIMEOUT:=120}
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # docs installed into the wrong directory
+ sed -e "/setup_args\['data_files'\] = /d" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ # Override faulty detection in setup.py, bug #510974.
+ export PYCURL_SSL_LIBRARY=${CURL_SSL}
+}
+
+src_test() {
+ emake -C tests/fake-curl/libcurl CC="$(tc-getCC)"
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local EPYTEST_DESELECT=(
+ # refcounting tests are unreliable
+ tests/memory_mgmt_test.py::MemoryMgmtTest::test_readdata_refcounting
+ tests/memory_mgmt_test.py::MemoryMgmtTest::test_writedata_refcounting
+ tests/memory_mgmt_test.py::MemoryMgmtTest::test_writeheader_refcounting
+ )
+
+ epytest -p flaky tests
+}
+
+python_install_all() {
+ local HTML_DOCS=( doc/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}