summaryrefslogtreecommitdiff
path: root/dev-python/pycryptodomex/pycryptodomex-3.9.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycryptodomex/pycryptodomex-3.9.8.ebuild')
-rw-r--r--dev-python/pycryptodomex/pycryptodomex-3.9.8.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/pycryptodomex/pycryptodomex-3.9.8.ebuild b/dev-python/pycryptodomex/pycryptodomex-3.9.8.ebuild
deleted file mode 100644
index c00030d4846c..000000000000
--- a/dev-python/pycryptodomex/pycryptodomex-3.9.8.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="A self-contained cryptographic library for Python"
-HOMEPAGE="https://www.pycryptodome.org https://github.com/Legrandin/pycryptodome https://pypi.org/project/pycryptodome/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2 Unlicense"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND="dev-libs/gmp:0
- virtual/python-cffi[${PYTHON_USEDEP}]
- !dev-python/pycrypto"
-BDEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}/pycryptodome-3.9.4-parallel-make.patch"
-)
-
-distutils_enable_tests setup.py
-
-python_prepare_all() {
- # parallel make fixes
- # Multiple targets were compiling the same file, setuptools doesn't
- # understand this and you get race conditions where a file gets
- # overwritten while it's linking. This makes the files look like separate
- # files so this race won't happen
- ln src/blowfish.c src/blowfish_eks.c || die
- ln src/mont.c src/mont_math.c || die
-
- distutils-r1_python_prepare_all
-}