summaryrefslogtreecommitdiff
path: root/dev-python/pycryptodome/files/pycryptodome-3.9.9-system-libtomcrypt.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycryptodome/files/pycryptodome-3.9.9-system-libtomcrypt.patch')
-rw-r--r--dev-python/pycryptodome/files/pycryptodome-3.9.9-system-libtomcrypt.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pycryptodome/files/pycryptodome-3.9.9-system-libtomcrypt.patch b/dev-python/pycryptodome/files/pycryptodome-3.9.9-system-libtomcrypt.patch
new file mode 100644
index 000000000000..927ad65e7c47
--- /dev/null
+++ b/dev-python/pycryptodome/files/pycryptodome-3.9.9-system-libtomcrypt.patch
@@ -0,0 +1,43 @@
+--- a/setup.py 2019-01-19 22:52:55.000000000 +0100
++++ b/setup.py 2019-02-15 15:29:46.960976879 +0100
+@@ -367,11 +367,13 @@ ext_modules = [
+ include_dirs=['src/'],
+ sources=["src/CAST.c"]),
+ Extension("Crypto.Cipher._raw_des",
+- include_dirs=['src/', 'src/libtom/'],
+- sources=["src/DES.c"]),
++ include_dirs=['src/'],
++ sources=["src/DES.c"],
++ extra_link_args=["-ltomcrypt"]),
+ Extension("Crypto.Cipher._raw_des3",
+- include_dirs=['src/', 'src/libtom/'],
+- sources=["src/DES3.c"]),
++ include_dirs=['src/'],
++ sources=["src/DES3.c"],
++ extra_link_args=["-ltomcrypt"]),
+ Extension("Crypto.Util._cpuid_c",
+ include_dirs=['src/'],
+ sources=['src/cpuid.c']),
+@@ -400,8 +402,9 @@ ext_modules = [
+ include_dirs=['src/'],
+ sources=["src/ARC4.c"]),
+ Extension("Crypto.Cipher._Salsa20",
+- include_dirs=['src/', 'src/libtom/'],
+- sources=["src/Salsa20.c"]),
++ include_dirs=['src/'],
++ sources=["src/Salsa20.c"],
++ extra_link_args=["-ltomcrypt"]),
+ Extension("Crypto.Cipher._chacha20",
+ include_dirs=['src/'],
+ sources=["src/chacha20.c"]),
+--- a/src/DES.c 2019-01-19 22:52:55.000000000 +0100
++++ b/src/DES.c 2019-02-15 15:30:27.014967034 +0100
+@@ -39,7 +39,7 @@ FAKE_INIT(raw_des3)
+
+ /* Include the actial DES implementation */
+ #define LTC_NO_PROTOTYPES
+-#include "libtom/tomcrypt_des.c"
++#include <tomcrypt.h>
+
+ struct block_state {
+ symmetric_key sk;