summaryrefslogtreecommitdiff
path: root/dev-python/pycountry/pycountry-22.1.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycountry/pycountry-22.1.10.ebuild')
-rw-r--r--dev-python/pycountry/pycountry-22.1.10.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pycountry/pycountry-22.1.10.ebuild b/dev-python/pycountry/pycountry-22.1.10.ebuild
new file mode 100644
index 000000000000..4fdb4fe48709
--- /dev/null
+++ b/dev-python/pycountry/pycountry-22.1.10.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+# The package uses pkg_resources to determine its version
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="Database of countries, subdivisions, languages, currencies and script"
+HOMEPAGE="https://github.com/flyingcircusio/pycountry"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~ppc ~riscv ~sparc ~x86"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests --install pytest
+
+# https://github.com/flyingcircusio/pycountry/pull/51
+PATCHES=( "${FILESDIR}/pycountry-20.7.3-fix-tests-for-pypy3.patch" )