summaryrefslogtreecommitdiff
path: root/dev-python/pycdio/pycdio-2.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycdio/pycdio-2.1.1.ebuild')
-rw-r--r--dev-python/pycdio/pycdio-2.1.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pycdio/pycdio-2.1.1.ebuild b/dev-python/pycdio/pycdio-2.1.1.ebuild
new file mode 100644
index 000000000000..635e1a54c837
--- /dev/null
+++ b/dev-python/pycdio/pycdio-2.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python OO interface to libcdio (CD Input and Control library)"
+HOMEPAGE="https://savannah.gnu.org/projects/libcdio/ https://pypi.org/project/pycdio/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+BDEPEND="dev-lang/swig"
+DEPEND=">=dev-libs/libcdio-2.0.0"
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # Remove obsolete sys.path and adjust 'data' paths in examples.
+ sed -i \
+ -e "s:^sys.path.insert.*::" \
+ -e "s:\.\./data:./data:g" \
+ example/*.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}