summaryrefslogtreecommitdiff
path: root/dev-python/pycares/pycares-3.0.0_p20190709.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycares/pycares-3.0.0_p20190709.ebuild')
-rw-r--r--dev-python/pycares/pycares-3.0.0_p20190709.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pycares/pycares-3.0.0_p20190709.ebuild b/dev-python/pycares/pycares-3.0.0_p20190709.ebuild
new file mode 100644
index 000000000000..12865ccb31f9
--- /dev/null
+++ b/dev-python/pycares/pycares-3.0.0_p20190709.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+EGIT_COMMIT=0c831407bc32c6e78a80c5b3d7865ba4c7ac26df
+MY_P=${PN}-${EGIT_COMMIT}
+
+DESCRIPTION="Python interface for c-ares"
+HOMEPAGE="https://github.com/saghul/pycares/"
+SRC_URI="https://github.com/saghul/pycares/archive/${EGIT_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Tests fail with network-sandbox, since they try to resolve google.com
+RESTRICT="test"
+
+# uses bundled/patched c-ares
+RDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" tests/tests.py -v || die
+}